Inventor

Die Integration von speedyPDM in Autodesk Inventor ® erfolgt als Addin.
Das speedyPDM Inventor-Addin liefert neben den üblichen Menüs und Werkzeugkästen noch ein Rollup-Fenster oder alternativ ein anheftbares Inventor-Fenster.

Rollup

Das Rollup–Fenster positioniert sich oberhalb der Titelleiste von Inventor und klappt automatisch auf, wenn Sie den Mauszeiger über die Titelleiste bewegen.

Rollup-Fenster

Das Rollup-Fenster klappt automatisch wieder zu, wenn Sie in Inventor arbeiten.

Das Rollup–Fenster hat einen ähnlichen Aufbau wie der speedy–Explorer mit Ausnahme der Navigationsleiste, die aus Platzgründen in Form einer Aufklappliste implementiert wurde.
Alternativ kann das Rollup-Fenster auch als anheftbares Inventor-Fenster dargestellt werden. Dabei kann dann das Fenster ebenfalls frei positioniert oder an einer Hauptfensterseite angeheftet werden.

Im oberen Bereich des Rollup–Fensters befindet sich der Navigationsbereich in Form einer Aufklappleiste.
Die Bedienung ist ähnlich der Navigation in speedy-Explorer.

Navigation im Rollup-Fenster

Mit Klick auf das [-] oder [+] Symbol wird der entsprechende Baum geöffnet bzw. geschlossen.
Gleiches erreicht man mit Doppelklick auf das Ordner-Symbol.
Ein Doppelklick auf einen Verzeichniseintrag stellt das Arbeitsverzeichnis ein und schließt das Navigationsfenster

Nach dem Anwählen eines Pfades werden im Hintergrund bereits die Dokumente angezeigt.

Rechts neben der Navigationsleiste finden befindet sich ein Werkzeugkasten zur Projekt- und Ordnerverwaltung:

SymbolBedeutung
In der Ordnerstruktur eine Ebene nach oben
Einen neuen Ordner anlegen.
Wenn in der Navigation das Schließfach aktiv ist wird ein neuer Projektordner angelegt.
Ist ein Projektordner oder ein anderer Ordner aktiv wird ein neuer Unterordner angelegt.
Ordnereigenschaften bearbeiten
Strukturansicht aktualisieren
Projektsichtbarkeit ein/aus.

Werkzeugleiste

SymbolBedeutung
Navigationshistorie zurück
Navigationshistorie vorwärts
Neues Dokument
Dokument öffnen (Modell oder Baugruppe)
Zeichnung öffnen
Dokument ablegen
Dokument freigeben
Dokument-Eigenschaften
Dokument ansehen
Dokument löschen
Ansicht aktualisieren
Dokument suchen
Benutzeroptionen

Neues Dokument anlegen

Es stehen verschiedene Möglichkeiten zur Auswahl:

Inventor:

  • Sie erstellen eine neue Datei mit dem Inventor-Befehl Datei » Neu.
  • Sie erzeugen das Model oder die Baugruppe mit den üblichen Inventor-Methoden.
  • Sie wählen den Inventor-Befehl Datei » Speichern.
  • Der speedy-Dialog „Neues Dokument“ erscheint.
    Machen Sie Ihre Angaben für den neuen Artikel.

Rollup-Fenster:

  • Wählen Sie den Befehl „Neues Dokument“.
  • Der speedy-Dialog Neues Dokument erscheint.
  • Machen Sie Ihre Angaben für den neuen Artikel.
    speedy legt ein neues Dokument an und erstellt eine leere Dokumentdatei anhand der Vorlage.
  • Der neue Artikel ist in der Dokumentenliste markiert.
  • Wählen Sie den Befehl „Dokument öffnen“.
  • Die leere Dokumentdatei wird geöffnet.

Datei öffnen

Es stehen verschiedene Möglichkeiten zur Auswahl:

Inventor:

  • Wählen Sie den Inventor-Befehl Datei » Öffnen.
  • Der speedy-Dialog Datei öffnen wird angezeigt.
  • Wählen Sie das gewünschte Dokument aus und bestätigen Sie den Dialog mit Öffnen

Rollup-Fenster:

  • Suchen Sie das zu öffnende Dokument.
  • Wählen Sie den Befehl „Dokument öffnen“.

Zeichnungen öffnen

Ribbon speedy » Zeichnung öffnen
Kontextmenü » Zeichnung öffnen

Öffnet die Zeichnung zu dem aktuell geöffneten Model (Teil/Baugruppe).
Wenn noch keine Zeichnung existiert wird automatisch eine Zeichnung anhand der Vorlagen, die im Dokumenttyp definiert sind, erzeugt und geöffnet.

Durch markieren einer Komponente in einer Baugruppe wird die Zeichnung der gewählten Komponente geöffnet.

Komponente öffnen

Ribbon speedy » Modell öffnen
Kontextmenü Baugruppe » Modell öffnen

Wenn Sie eine Baugruppe geöffnet haben und das Model eine Komponente oder eine Unterbaugruppe zum Bearbeiten öffnen möchten müssen Sie den speedy Befehl Modell öffnen verwenden. Teile und Unterbaugruppen werden beim Öffnen einer Baugruppe nur im schreibgeschützten Modus geladen, um unnötiges entnehmen aus der speedy – Datenbank und unbeabsichtigtes verändern zu verhindern. Wenn Sie also den Inventor - Befehl zum Öffnen von Teilen verwenden, werden diese schreibgeschützt geöffnet.

Komponente einfügen

Sie haben eine Baugruppe geöffnet und möchten ein bestehendes Teil oder eine andere Baugruppe einfügen. Es stehen Ihnen verschiedene Möglichkeiten zur Auswahl:

Inventor:

  • Wählen Sie den Inventor-Befehl Einfügen » Komponente platzieren ».
  • Der speedy-Dialog Datei öffnen wird angezeigt.
  • Wählen Sie das gewünschte Dokument aus und bestätigen Sie den Dialog mit ÖFFNEN.

Rollup-Fenster:

  • Suchen Sie das zu öffnende Dokument.
  • Markieren Sie das Dokument in der Dokumentliste
  • Ziehen Sie mit gedrückter linker Maustaste in den Zeichenbereich von Inventor (Drag & Drop).
  • Das Teil oder die Baugruppe, die mit dem Dokument verknüpft ist wird in die aktuelle Baugruppe eingefügt und „hängt“ am Mauszeiger.

Wenn das Dokument Konfigurationen enthält oder ein Variantenteil ist erscheint nach dem Einfügen der Dialog Variante bearbeiten.

Entnehmen

Entnimmt die aktuelle Datei oder die markierte Komponente zum Bearbeiten.
Wenn Sie eine Datei nur zum Ansehen geöffnet haben können Sie mit dem Befehl Entnehmen die aktuelle Datei in Arbeit nehmen.
Eine markierte Unterkomponente einer Baugruppe wird durch den Befehl in Arbeit genommen und geöffnet.

Artikel-Eigenschaften

Bearbeitet die Artikel-Eigenschaften des aktuellen Artikels oder der markierten Komponente.
Nach beenden des Eigenschaften-Dialogs werden die iProperties entsprechend der Konfiguration aktualisiert.
Wird der Befehl in einer Zeichnung ausgeführt wird anschließend der Schriftkopf aktualisiert.

Speichern

Beim Speichern von Baugruppen wird überprüft, ob die Baugruppe noch Teile oder Unterbaugruppen enthält, die nicht dem aktuellen Projekt angehören.
Die Hinweismeldung kann nur mit OK bestätigt werden. Die Datei wird aber auf jeden Fall gespeichert. Verwenden Sie den Befehl Komponente umbenennen, um projektfremde Teile umzubenennen.

Wird die aktuelle Datei mehrfach verwendet erscheint beim Speichern ebenfalls ein Hinweisfenster:

Sie haben nun die Möglichkeit die Datei unter einer neuen Artikelnummer abzulegen oder unter gleichem Namen zu speichern.

Wenn in einer Baugruppe eine referenzierte Datei verändert wurde erscheint ein erweiterter Dialog mit Auflistung aller referenzierter Dateien:

Die Liste zeigt folgende Informationen an:

SpalteÜberschriftBeschreibung
1 zu speichernde Datei Dateiname der referenzierten Datei.
2 Status Aktueller Dokument-Status (Abgelegt, In Arbeit, Freigegeben, …)
3 Geändert In einem Tooltip wird die Art der Änderung in der Datei erläutert.
4 Schreibgeschützt Das Symbol zeigt an, ob die Datei aktuell einen Schreibschutz hat (geschlossenes Schloss) oder beschreibbar ist (geöffnetes Schloss).
5 Speichern Kontrollkästchen zur Markierung der zu speichernden Dateien. Nur Dateien die auch beschreibbar sind können gespeichert werden.
6 Bemerkung Hinweistext oder Fehlermeldung.
  • Durch Doppelklick auf das Statussymbol in einer Zeile wird das Dokument in Arbeit genommen und kann ebenfalls gespeichert werden.
  • Der Befehl [Entnehmen] nimmt das Dokument der selektierten Zeile in Arbeit.
  • Der Befehl [Ja für alle] markiert alle Dateien zum Speichern, die auch speicherbar sind (entnommen durch den aktuellen Benutzer).
  • Der Befehl [Nein für alle] entfernt die Markierung zum Speichern.

Tritt während des Speicherns ein Fehler bei einer Datei auf wird dies in der Bemerkungsspalte protokolliert.
Bei erfolgreichem Speichern schließt der Dialog automatisch.

Speichern und Schließen

Zum Schließen eines in speedy verwalteten Datei sollten Sie den Befehl Speichern+Schließen aus dem speedy–Menü wählen.

Ribbon speedy » Speichern+Schließen

Das Modell wird in das Fenster gezoomt und eine Isometrische Ansicht eingestellt, um eine aussagekräftige Dateivorschau zur Verfügung zu erhalten, anschließend wird die Datei gespeichert und geschlossen.

Komponenten kopieren und ersetzen

Der Befehl „Komponente kopieren und ersetzen“ dient zum umbenennen von projektfremden Bauteilen oder zum einpflegen noch nicht verwalteter Dateien.

Ribbon speedy » Komponente ersetzen
Kontextmenü Baugruppe » Komponente ersetzen

Es erscheint folgender Dialog:

Der Dialog zeigt die komplette Baugruppenstruktur mit allen referenzierten Dateien. Markieren Sie alle Komponenten, die Sie ersetzen möchten.

Die Baumstruktur unterscheidet in der Anzeige folgende Merkmale:

  • Einträge in grüner Schrift stellen ein bereits bekanntes speedy-Dokument dar.
  • Einträge in blauer Schrift stellen eine unbekannte lokale Datei dar.
  • Einträge in roter Schrift stellen eine nicht vorhandene Datei dar.
  • Einträge in grauer Schrift stellen eine zusätzliche gleichbenannte Datei zu einem Haupteintrag dar.
  • Fett geschriebene Einträge sind Haupteinträge zu denen es evtl. noch weitere gleichbenannte Dateien gibt.

Durch betätigen der Schaltfläche „Automatisch wählen“ werden alle Projektfremden Komponenten automatisch markiert. Durch bestätigen der Schaltfläche OK werden die markierten Komponenten der Reihe nach umbenannt. Je nach Option „Neue Artikelnummer manuell vergeben“ oder „Artikeleigenschaften bearbeiten“ erscheinen für jeden neuen Artikel weitere Dialoge.

Komponente aktualisieren

Ersetzt die ausgewählte Komponente durch die aktuellste Version des Artikels.

Teilverwendung

Zeigt die Teileverwendung der aktuellen Datei oder der markierten Komponente an.

Referenz-Manager

Öffnet den Referenz-Manager für die aktuelle Baugruppendatei (siehe auch Referenz-Manager).

Kaufteile/U-Teile

Häufig müssen Kauf-, Norm- oder Kundenteile mit Hilfe einer Baugruppendatei (Assembly) und mehrerer Teiledateien (Parts) beschrieben werden. Ein typischen Beispiel ist ein Pneumatik-Zylinder. Damit Bewegung oder verschiedene Einbauzustände benutzt werden können muss eine Baugruppendatei mit entsprechenden Teiledateien konstruiert werden. Seitens der Verwaltung interessiert aber nur der Zylinder als ganzer.
Hierzu werden entweder alle Dokumenttypen, die keine Stückliste haben als „Teile“-Dokumenttyp behandelt oder mit dem Konfigurationsparameter [inventor.partrename.partdoctypes] werden die Dokumenttypen aufgezählt.

Wenn nun in Inventor eine Baugruppendatei in speedy abgelegt und im Neu-Dialog ein „Teile-„Dokumenttyp gewählt wird, werden alle Komponenten automatisch als U-Teile abgelegt:

Kaufteil-Zylinder mit U-Teilen



Weitere U-Teile hinzufügen
Wenn Sie einem vorhandenen Kaufteil weitere U-Teile hinzufügen möchten fügen Sie der Inventor Baugruppe die Komponente mit den üblichen Mitteln hinzu.
Nun verwenden Sie den speedy Befehl „Komponente kopieren und ersetzen“.

Wählen Sie die Komponente aus und markieren Sie sonst nichts im Dialog.
Die Komponente wird nun automatisch dem speedy-Dokument als U-Teil hinzugefügt und entsprechend umbenannt.

U-Teile ersetzen
Wenn Sie bei einem vorhandenen Kaufteil bestimmte U-Teile austauschen müssen öffnen Sie die Inventor Baugruppe zur Bearbeitung.
Tauschen Sie nun die gewünschten U-Teile durch die neuen Komponenten aus.
Nun verwenden Sie den speedy Befehl „Komponente kopieren und ersetzen“.
Wählen Sie die Komponente aus und markieren Sie sonst nichts im Dialog.
Die Komponente wird nun automatisch dem speedy-Dokument als U-Teil hinzugefügt und entsprechend umbenannt.

Spiegeln

speedyPDM unterstützt beim Spiegeln von einzelnen Teilen wie auch Baugruppen. speedyPDM greift dabei in den Speichern-Dialog von Inventor ein.

Verwenden Sie die bekannten Mechanismen zum Spiegeln von Teilen oder Baugruppen in Inventor:

Wählen Sie die zu spiegelnden Teile oder Baugruppen. Definieren Sie die entsprechenden Spiegelachsen.

Den anschließenden Dialog zur Bestimmung der Dateinamen bestätigen Sie mit [OK]:

Je nach Konfiguration erscheint nun für jede zu spiegelnde Komponente der speedy Neu-Dialog.

Die folgenden Konfigurationsparameter steuern das Verhalten:

NameBeschreibung
inventor.mirror.name Bezeichnungen (durch Semikolon getrennt), die bei gespiegelten Teilen verwendet und von speedy erkannt werden. (z.B. _MIR)
inventor.mirror.createtype Definiert die Art der Dokumenterstellung nach dem Spiegeln von Teilen:
- 0 : MirrorName, der Name des gespiegelten Teils wird auch als neue Dokumentnummer verwendet.
- 1 : AutoCreate, eine neue Dokumentnummer wird automatisch erstellt.
- 2 : UserCreate, der Anwender kann mit Hilfe des Neu-Dialogs den neuen Dokumenttyp definieren.
Bitte beachten Sie:
Wenn ein Ursprungsteil geändert wird, wird auch das gespiegelte Teil in Arbeit genommen.
Damit die Änderungen auch im gespiegelten Teil übernommen werden sollten Sie das gespiegelte ebenfalls öffnen.
Durch die Freigabe eines gespiegelten Teils wird das Ursprungsteil nicht freigegeben.
Gespiegelte Teile sollten nicht direkt freigegeben werden. Geben Sie immer nur das Ursprungsteil frei.

Stückliste bearbeiten

Ribbon speedy » Stückliste bearbeiten
Kontextmenü Baugruppe » Stückliste bearbeiten

Öffnet den Stücklistendialog mit der aktuellen Baugruppen-Stückliste. Wenn noch keine Stückliste vorhanden ist, wird die Stückliste automatisch erstellt.

Zur Aktualisierung der speedy Stückliste wird die Inventor Baugruppe analysiert.

Wenn Sie eine Baugruppe in Inventor geöffnet haben sollten Sie die Stückliste ausschließlich über den Stücklistenbefehl in Inventor bearbeiten.
Nur so ist sichergestellt, dass Änderungen an der Stückliste sofort in der geöffneten Baugruppe übernommen werden.

Baugruppe und Zeichnung geöffnet:
Wenn Sie die Baugruppe und die zugehörige Zeichnung geöffnet haben müssen Sie nach Änderungen in der Baugruppe speichern bevor Sie in die Zeichnung wechseln.
Beim Speichern wird die speedy Stückliste aktualisiert. Damit ist sichergestellt, dass Stücklistenänderungen sofort in der Zeichnung sichtbar werden.

Speichern als

Speichert die aktive Datei in einem zusätzlichen Dateiformat ab.
Die Zusatzdatei wird mit gleichen Dateinamen im gleichen Verzeichnis wie die aktuelle Datei abgelegt. Je nach geöffnetem Dateityp (ipt, iam, idw) stehen ihnen unterschiedliche Speicherformate zur Verfügung.

Benutzeroptionen

Öffnet den Dialog zur Bearbeitung der Benutzeroptionen.

Meldungen zurücksetzen

Einige Warnhinweise, Fehlermeldungen und Benutzerabfragen können durch Auswahl einer Option „Diese Frage nicht nochmal stellen“ oder „Diesen Hinweis nicht nochmal melden“ im Dialog der Meldung deaktiviert werden. Diese deaktivierten Meldungen können mit Hilfe dieses Befehls wieder aktiviert werden. Es erscheint ein Dialog mit allen deaktivierten Meldungen. Markieren Sie alle Meldungen, die wieder aktiviert, also beim nächsten vorkommen wieder erscheinen sollen und bestätigen den Dialog mit OK.

Variantenartikel

Im Karteireiter Varianten des Artikelstamms wird definiert, ob der Artikel ein Variantenteil ist.
Eine Variante wird in Inventor mit Hilfe von iPart bzw. iAssemblies beschrieben.
Variantenteile werden durch eine Variantendefinition (Elterndefinition) beschrieben, die als Basis für die Varianten (Kind-Artikel) dient.

Der Elternartikel beschreibt in einer Art Vorlage für die Kind-Artikel und deren Eigenschaften.

Bedeutung der Eingabefelder:

Variantentyp Definiert den Variantentyp:
Variantenteil := Varianten–Einzelteil
Variantenbaugruppe := Varianten–Baugruppe
Flexibles Einbauteil :=
Flexible Baugruppe :=
Variantenname Im Falle von Inventor iParts oder iAssemblies darf hier keine Angabe erfolgen. speedy verhält sich passiv, d.h. Die Namen der Varianten werden durch Inventor vorgegeben und gesteuert. speedy übernimmt lediglich diese Namen.
Der Dokumentenname einer Variante (Kind-Artikel) setzt sich wie folgt zusammen:
[Dokumentenname Elternartikel] / [Variantenname]
Beschreibung – Leer –
Basiskonfiguration – Leer –
Erstellen von weiteren Varianten sperren Hat in Inventor keine Auswirkung.
Neue Variante als neuer Auftrags-Artikel anlegen Hat in Inventor keine Auswirkung.
Variantenzeichnung Hat in Inventor keine Auswirkung.
Variablen Liste der Variablen (alle Inventor-Bemaßungen beginnend mit var_).
Für jede Variable kann ein Gültigkeitsbereich definiert werden.
Bitte beachten Sie, dass der Variantenname (Konfigurationsname in Inventor) keinen Schrägstrich “/“ enthält.

Die Eigenschaften des Grundartikels werden auf die Varianten vererbt. Wenn z.B. im Grundartikel die Benennung 1 ausgefüllt ist erhalten alle Varianten die gleiche Benennung 1. In den Varianten ist die Benennung 1 gesperrt, da dieses Eigenschaft vom Grundartikel geerbt wurde.

Wir im Grundartikel allerdings eine Eigenschaft nicht ausgefüllt kann sie in den Varianten ausgefüllt werden. Die Eigenschaft ist in den Varianten nicht gesperrt.

Soll eine Eigenschaft bereits mit einem Wert vorgegeben werden aber in der Variante soll es möglich sein diese Vorgabe zu überschreiben muss dem eingegebenen Wert im Grundartikel ein Tilde ~ vorangestellt werden. Die Variante zeigt nun den vorgegebenen Wert des Grundartikels an. Die Eigenschaft ist aber in den Varianten nicht gesperrt und kann überschrieben werden.

Die Eigenschaften der Varianten können auch mit Hilfe von Formeln beschrieben. Dabei wird die Formel im Grundartikel hinterlegt und kann sich Beispielweise auf eine Abmessung aus dem Modell beziehen.
Starten Sie den Formeleditor indem Sie mit gedrückter Steuerungstaste [Strg] in ein Eingabefeld doppelklicken oder durch betätigen der Schaltfläche [fx] (siehe auch Formelinterpreter).

Bitte beachten
Varianten-Artikel (iPart/iAssembly) aus Inventor können nicht kopiert werden.
Referenzen auf Varianten-Artikel (iPart/iAssembly) aus Inventor können nicht durch den Referenzmanager getauscht werden.
Diese Einschränkungen haben technische Gründe seitens Inventor.

Installation

Systemvoraussetzungen

Für folgende Inventor Versionen steht ein Addin zu verfügung:

Inventor Versionspeedy Addin
Inventor 2010-2015 wird nicht mehr unterstützt
Inventor 2016 aisSpeedy72016.dll (Support endet 2020)
Inventor 2017 aisSpeedy72017.dll (Support endet 2020)
Inventor 2018 aisSpeedy72018.dll (Support endet 2021)
Inventor 2019 aisSpeedy72019.dll
Inventor 2020 aisSpeedy72020.dll
Inventor 2021 aisSpeedy72021.dll
Inventor 2022 aisSpeedy72022.dll

Addin registrieren

Zusatzmodule-Manager aufrufen


Fenster Zusatzmodul-Manager


Wenn Sie das Installationsprogramm für den Clientarbeitsplatz verwendet haben wird das Inventor-Addin automatisch registriert. Manuell kann das Inventor-Addin mit Hilfe der Batchdatei register_inventor.cmd installiert werden. Starten Sie die Batchdatei register_inventor.cmd aus dem jeweiligen Plattform-Unterordner (bin32 oder bin64) des speedy Verzeichnisses. Die Batchdatei registriert immer das neueste Inventor-Addin. Möchten Sie eine bestimmte Addin Version installieren können Sie die Registrierung auch per Befehlszeile durchführen. Öffnen Sie hierzu eine Eingabeaufforderung und geben folgenden Befehl ein:

regsvr32.exe \\<servername>\speedy_bin$\bin32\aisSpeedy72018.dll 
oder
regsvr32.exe \\<servername>\speedy_bin$\bin64\aisSpeedy72018.dll 

In Autodesk Inventor können Sie mit Hilfe des Zusatzmodul-Managers kontrollieren, ob speedy korrekt registriert wurde und das Ladeverhalten steuern.

Apprentice Server registrieren

Der Apprentice Server ist ein von Autodesk zur Verfügung gestellter Mechanismus, um Anwendungen Zugang zu Inventor-Dateiinformationen zu geben. Mit Hilfe des Apprentice Servers werden in speedy/PDM Referenzen von Inventor Baugruppen, Teilen und Zeichnungen ermittelt und getauscht.

Bitte beachten Sie, dass mit Hilfe von Apprentice ausschließlich Referenzen getauscht werden können wenn die Dateiversion der aktuellen Inventor-/Apprentice-Version entspricht. Dies ist eine Limitierung seitens Autodesk. Es ist demnach nicht möglich Referenzen von älteren Dateiversionen zu tauschen.
Wenn Sie also einen Programmwechsel von Inventor planen sollten Sie unbedingt ihren Zeichnungsbestand konvertieren.

Der Apprentice Server kann nur außerhalb von Inventor genutzt werden. Damit die Referenzen aber auch innerhalb von Inventor (z.B. Befehle im speedy/Rollup) getauscht werden können bringt speedy einen zusätzlichen Mechanismus mit. Der speedy/Apprentice „dwApprentice“ muss ebenfalls registriert werden:

x:\speedy\bin64\dwApprentice.exe /RegServer


Ab Inventor Version 2019 wird der Apprentice Server von Autodesk nur noch als 64-Bit Version geliefert. Damit ist es eigentlich nicht mehr möglich, dass 32-Bit Anwendungen diesen Mechanismus verwenden. Aber auch hierfür liefert speedy eine entsprechende Lösung. Nach Installation oder Update von Autodesk Inventor 2019 muss die Datei „Inventor2019Surrogate.reg“ der Registry hinzugefügt werden:

regedit x:\speedy\inst\redist\Inventor2019Surrogate.reg


Client Installation/Update

Die oben genannten Installationsschritte werden automatisch durch das Client Setup Programm (speedy-client.exe) durchgeführt. Alternativ können Sie aber auch z.B. nach einem Inventor-Update oder Upgrade die Batchdatei register_inventor.cmd aufrufen.

x:\speedy\bin64\register_inventor.cmd


Arbeitsumgebung

Inventor verwendet Projekte zur Organisation und zum Zugriff auf Dateien, die mit einem bestimmten Konstruktionsauftrag verbunden sind.
Für Projekte wird eine Projektdatei (.ipj) verwendet, um die Pfade zu den Ordnern zu speichern, in denen sich Ihre Konstruktionsdaten befinden.
Erstellen Sie eine Projektkonfiguration, die als Arbeitsbereich auf den den speedy-Vault verweist oder als Speicherort den speedy-Vault verwendet.
Wählen Sie beim Erstellen des Projektes den Typ „Neues zentrales Projekt“. Alle weiteren Einstellungen entnehmen Sie bitte dem Inventor Handbuch.

Administration

Dateieigenschaften

Die Zuordnung von speedy/PDM Dokumenteigenschaften zu Dateieigenschaften erfolgt mit Hilfe einer Konfigurations- und Zuordnungsdateien (siehe hierzu auch Konfiguration).
Die Konfigurationsdateien befinden sich im Unterverzeichnis „\config“.

Zuordnung der Dokumenteigenschaften zu iProperties

Die Zuordnung der Dokumenteigenschaften zu den iProperties erfolgt in der Konfigurationsdatei aisSpeedy.ini.

Inventor teilt die Dateieigenschaften (iProperties) in mehrere Bereiche auf:

NameInterner NameAnzeigename
Inventor Summary Information {F29F85E0-4FF9-1068-AB91-08002B27B3D9} Inventor - Zusammenfassungsinformationen
Inventor Document Summary Information {D5CDD502-2E9C-101B-9397-08002B2CF9AE} Inventor - Zus.-fassungsinfo f. Dokument
Design Tracking Properties {32853F0F-3444-11D1-9E93-0060B03C1CA6} Design Tracking - Eigenschaften
Inventor User Defined Properties {D5CDD505-2E9C-101B-9397-08002B2CF9AE} Inventor - Benutzerdefinierte Eigenschaften

Die benutzerspezifischen Eigenschaften werden ganz normal per Attribute-Mapping zugeordnet. Die Inventor spezifischen Dateieigenschaften (iProperties) werden über den Bereich adressiert:

AnzeigenameName
Titel Title@Inventor Summary Information
Thema Subject@Inventor Summary Information
Author Author@Inventor Summary Information
Schlüselwörter Keywords@Inventor Summary Information
Kommentar Comments@Inventor Summary Information
Revisionsnummer Revision Number@Inventor Summary Information
Kategorie Category@Inventor Document Summary Information
Manager Manager@Inventor Document Summary Information
Firma Company@Inventor Document Summary Information
Erstellungsdatum Creation Time@Design Tracking Properties
Bauteilnummer Part Number@Design Tracking Properties
Projekt Project@Design Tracking Properties
Kostenstelle Cost Center@Design Tracking Properties
Kontrolliert von Checked By@Design Tracking Properties
Kontrolldatum Date Checked@Design Tracking Properties
Konstruktion genehmigt von Engr Approved By@Design Tracking Properties
Genehmigungsdatum Konstr. Engr Date Approved@Design Tracking Properties
Status User Status@Design Tracking Properties
Material Material@Design Tracking Properties
Web-Verknüpfung Catalog Web Link@Design Tracking Properties
Bezeichnung Description@Design Tracking Properties
Zulieferer Vendor@Design Tracking Properties
Dateiuntergruppe Document SubType Name@Design Tracking Properties (readonly)
Fertigung genehmigt von Mfg Approved By@Design Tracking Properties
Genehmigungsdatum Fertig. Mfg Date Approved@Design Tracking Properties
Geschätzte Kosten Cost@Design Tracking Properties
Konstrukteur Designer@Design Tracking Properties
Ingenieur Engineer@Design Tracking Properties
Bevollmächtigter Authority@Design Tracking Properties
Bestandsnummer Stock Number@Design Tracking Properties
Konstruktionsstatus Design Status@Design Tracking Properties
Manufacturer@Design Tracking Properties
Language@Design Tracking Properties
Categories@Design Tracking Properties
Weld Material@Design Tracking Properties
Mass@Design Tracking Properties
SurfaceArea@Design Tracking Properties
Volume@Design Tracking Properties
Density@Design Tracking Properties
Valid MassProps@Design Tracking Properties
Flat Pattern Width@Design Tracking Properties
Flat Pattern Length@Design Tracking Properties
Flat Pattern Area@Design Tracking Properties
Sheet Metal Rule@Design Tracking Properties
Sheet Metal Width@Design Tracking Properties
Sheet Metal Length@Design Tracking Properties
Sheet Metal Area@Design Tracking Properties
Standard@Design Tracking Properties

Inhaltscenter-Teile in Stücklisten

Zuordnung der iProperties von Inhaltscenter-Teilen zu Stücklisteneigenschaften erfolgt in der Konfigurationsdatei aisStandard.ini.
Werden Inhaltscenter-Teile nicht in speedy verwaltet muss eine iProperties Zuordnung zu speedy Eigenschaften erfolgen damit die Inhaltscenter-Teile in der speedy Stückliste erfasst werden können. Damit ein Stücklistenposition aus Inventor auch in speedy übernommen wird muss die Position entweder bereits ein verwaltetes Dokument sein oder eine Eigenschaft als Dokumentnummer (dm_docno) zugeordnet werden.

Neben allen typischen iProperties stehen folgende besondere Eigenschaften zur Verfügung:

inventor.partnumber Bauteilnummer
inventor.configuration.name Variantenname bei iPart/iAssembly
inventor.component.path Pfad der Komponente
[ATTRIBUTE_MAP]
dm_docno  = "inventor.partnumber"
dm_title  = "inventor.partnumber"
BEN1      = "Description"

Erweiterte Anpassung

Mit Hilfe der Script-Datei „aisSpeedy.vbs“ können weitere Anpassungen in Autodesk Inventor vorgenommen werden. Die Script-Datei befindet sich im speedy Unterverzeichnis „\script“ und wird beim Laden des Addin ebenfalls geladen.
Im Script kann auf verschiedene Ereignisse in Autodesk Inventor und dem speedy-Addin reagiert werden. Folgende Ereignisfunktionen stehen zur Verfügung:

EreignisroutineBeschreibung
OnInit Wird nach dem Initialisieren des Addin aufgerufen.
OnFileSave Wird beim Speichern einer Datei aufgerufen (vgl. Inventor API ApplicationEvents.OnSaveDocument).
OnFileSaveAs Wird beim Speichern unter einer Datei aufgerufen (vgl. Inventor API ApplicationEvents.OnSaveDocument).
OnFileCheckIn Wird beim Speichern und Schließen eines Dokuments aufgerufen.
OnFileRelease Wird beim Freigeben eines Dokuments aufgerufen.
OnReleaseRecreate_SaveAs Wird aufgerufen, wenn die Freigabe im speedy-Explorer erfolgt und zusätzliche Dateien (z.B.: pdf) erneuert werden müssen. Die Funktion wird für jede zu erstellende Datei separat aufgerufen.
OnCmdSaveAsDWF Wird vom speedy Befehl „Speichern als DWF“ aufgerufen.
OnCmdSaveAsDWFx Wird vom speedy Befehl „Speichern als DWFx“ aufgerufen.
OnCmdSaveAsDWG Wird vom speedy Befehl „Speichern als DWG“ aufgerufen.
OnCmdSaveAsDXF Wird vom speedy Befehl „Speichern als DXF“ aufgerufen.
OnCmdSaveAsBMP Wird vom speedy Befehl „Speichern als BMP“ aufgerufen.
OnCmdSaveAsGIF Wird vom speedy Befehl „Speichern als GIF“ aufgerufen.
OnCmdSaveAsJPG Wird vom speedy Befehl „Speichern als JPG“ aufgerufen.
OnCmdSaveAsPDF Wird vom speedy Befehl „Speichern als PDF“ aufgerufen.
OnCmdSaveAsPNG Wird vom speedy Befehl „Speichern als PDF“ aufgerufen.
OnCmdSaveAsX_B Wird vom speedy Befehl „Speichern als X_B“ aufgerufen.
OnCmdSaveAsX_T Wird vom speedy Befehl „Speichern als X_T“ aufgerufen.
OnCmdSaveAsSAT Wird vom speedy Befehl „Speichern als SAT“ aufgerufen.
OnCmdSaveAsSTEP Wird vom speedy Befehl „Speichern als STEP“ aufgerufen.
OnCmdSaveAsSTEP203 Wird vom speedy Befehl „Speichern als STEP203“ aufgerufen.
OnCmdSaveAsSTEP214 Wird vom speedy Befehl „Speichern als STEP214“ aufgerufen.
OnCmdSaveAsTIF Wird vom speedy Befehl „Speichern als TIF“ aufgerufen.
OnCmdSaveAsXGL Wird vom speedy Befehl „Speichern als XGL“ aufgerufen.
OnCmdSaveAsZGL Wird vom speedy Befehl „Speichern als ZGL“ aufgerufen.

Konfigurationsparameter

inventor.
SchlüsselBeschreibung
inventor.autoset.color Die am Material (der Klasse) eingestellte Farbe wird dem Teil zugewiesen.
inventor.autoset.material Definiert ob beim Öffnen automatisch das Material gesetzt werden soll.
inventor.bomtable.autocreate Definiert ob speedy automatisch eine Stückliste beim Speichern erstellen soll.
inventor.bomtable.autosave Alle Änderungen werden automatisch gespeichert.
inventor.bomtable.autosorted Die Stückliste wird immer automatisch sortiert.
inventor.bomtable.autofreepos Anzahl an freien Positionen zwischen den einzelnen Sortierkriterien.
inventor.bomtable.basepartignore Artikel aus Stammartikel-Ordnern ignorieren.
inventor.bomtable.fixed Der Konfigurationsparameter steuert das Verwenden der Positionsnummern der Inventor Stückliste
0 := Positionsnummern können in speedy geändert werden abhängig von der Sperre in Inventor.
1 := Alle Positionsnummern werden als fixiert interpretiert, d.h. die Positionsnummer aus Inventor wird immer übernommen. Die Positionsnummernbearbeitung ist in speedy gesperrt.
inventor.bomtable.filterunhandled
inventor.bomtable.folderignore Definiert ob die Komponenten (siehe solidworks.bomtable.foldernames) bei der Stücklistenermittlung ignoriert werden.
inventor.bomtable.foldernames Komponenten, die einem Feature-Ordner zugeordnet wurden werden nicht in die Stückliste aufgenommen, wenn der Ordnername in der Liste definiert wurde. Durch Semikolon getrennte Aufzählung der Ordnernamen.
inventor.bomtable.pathignore Definiert ob die Komponenten (siehe solidworks.bomtable.pathnames) bei der Stücklistenermittlung ignoriert werden.
inventor.bomtable.pathnames Komponenten, die aus einem der angegebenen Verzeichnisse stammen werden nicht in die Stückliste aufgenommen.
inventor.bomtable.summarize Stücklistenpositionen beim Einlesen der Inventorstückliste aufsummieren.
Standardwert:=0
Inventor summiert gleiche Teile bereits selbstständig auf.
inventor.bomtable.traverschildcomponents Definiert ob Unterbaugruppen mit in die Stückliste übernommen werden.
inventor.checkin.firstsheet Beim „Speichern & Schließen“ einer Zeichnung erstes Blatt aktivieren.
inventor.checkin.forcesave Beim „Speichern & Schließen“ immer Speichern.
inventor.checkin.shownamedview Standardansicht beim „Speichern & Schließen“ einstellen.
inventor.checkoutondrag
inventor.component.attachinvisble
inventor.configuration.forceupdate Definiert ob das aktualisieren der Variantenliste beim Speichern erzwungen wird.
inventor.configuration.purgereleased Bei bereits zuvor freigegebenen Artikeln nicht mehr benötigte Varianten löschen.
inventor.configuration.prefix
inventor.document.openfiletype
inventor.document.openfiletype2
inventor.documentlist.coldescnameStandardspaltenbeschreibung für Dokumentenliste im Rollup
inventor.dropcreatenew.editobject
inventor.extensions
inventor.mirror.name Bezeichnungen die bei gespiegelten Teilen verwendet und von speedy erkannt werden. (z.B. _MIR)
inventor.mirror.createtype Definiert die Art Dokumenterstellung nach dem Spiegeln von Teilen:
- 0 : MirrorName, der Name des gespiegelten Teils wird auch als neue Dokumentnummer verwendet.
- 1 : AutoCreate, eine neue Dokumentnummer wird automatisch erstellt.
- 2 : UserCreate, der Anwender kann mit Hilfe des Neu-Dialogs den neuen Dokumenttyp definieren.
inventor.material.synchronize Das Zurückschreiben von Material in die Artikeleigenschaften kann gesteuert werden.
1 := Material wird zurück geschrieben (Standard)
0 := Material wird nicht zurück geschrieben.
inventor.multipleuse.onsavecheck Prüfung auf Mehrfachverwendung beim speichern:
0 := nicht prüfen
1 := Warnen und User Befragen
2 := Automatisch als neues Teil/Baugruppe abspeichern
3 := Warnen und User Befragen,
wenn Antwort „trotzdem speichern“ nichts tun sonst automatisch als neues Teil/Baugruppe abspeichern.
inventor.multipleuse.savesilent
inventor.partrename.autoondrop Beim Drag & Drop projektfremde Teile automatisch umnummerieren.
inventor.partrename.completestruct Definiert ob beim umnummerieren von Komponenten auch die gesamte Struktur der Unterbaugruppen abgearbeitet werden soll.
inventor.partrename.oninsert Definiert, ob die Ermittlung projektfremder Teile bei jedem Einfügen einer Komponenten ausgeführt werden soll.
inventor.partrename.partdoctypes
inventor.partrename.pathignore Definiert ob beim Ermitteln projektfremder Teile Komponenten in definerten Verzeichnissen (siehe solidworks.partrename.pathnames) ignoriert werden sollen.
inventor.partrename.pathnames Definiert die Verzeichnisse die beim Ermitteln projektfremder Teile ignoriert werden sollen. Durch Semikolon getrennte Aufzählung von Verzeichnissen.
inventor.propertyview.autoswitch Definiert das der Karteireiter Anhangteile aktiv geschaltet wird, wenn das Dokument Anhangteile besitzt. Wenn Varianten vorhanden sind, wird der Karteireiter Varianten aktiv geschaltet (SolidWorks Rollup).
inventor.propertyview.configurations
inventor.propertyview.defaulttab Das System merkt sich den zuletzt aktiven Karteireiter für den nächsten Programmaufruf.
inventor.propertyview.document Definiert ob der Karteireiter Dokument angezeigt wird (Im speedy Rollup Fenster)
inventor.propertyview.files Definiert ob der Karteireiter Dateien angezeigt wird.
inventor.propertyview.library Definiert ob der Karteireiter Anhangteile angezeigt wird.
inventor.propertyview.properties Definiert ob der Karteireiter Eigenschaften angezeigt wird.
inventor.propertyview.relations Definiert ob der Karteireiter Relationen angezeigt wird.
inventor.propertyview.revisions Definiert ob der Karteireiter Versionen angezeigt wird.
inventor.propertyview.whereused
inventor.relation.forceupdate Definiert ob beim Speichern einer Baugruppe die Relationen immer aktualisiert werden sollen.
inventor.revision.count Anzahl Revisionseinträge in der Revisionstabelle.
inventor.revision.first Erste anzuzeigende Revision. Ein Wert von 1 bedeutet die Revisionstabelle beginnt mit der 1. Freigabe.
Standardwert := 1
inventor.revision.firstline Nur 1. Zeile des Änderungskommentars in die Versionstabelle schreiben.
inventor.revision.revlabel Formatierung der Revisionsbezeichnung im Änderungsindex
siehe auch [session.revlabel]
inventor.rollup.autorefresh Definiert ob beim aufklappen des Rollup Fensters die Dokumentenliste automatisch aktualisiert werden soll.
inventor.rollup.delay Definiert in 250ms Schritten die Verzögerungszeit für das Zuklappen des Rollup Fensters.
inventor.rollup.delta
inventor.rollup.deltaremember
inventor.rollup.dockable Zeig das speedy-Fenster entweder als andockbares Inventor-Fenster oder als Rollup-Fenster an.
inventor.rollup.unrolltimer Definiert in 250ms Schritten die Verzögerungszeit für das Aufklappen des Rollup Fensters.
inventor.rollup.show Rollup-Fenster anzeigen ja/nein.
inventor.save.dependent Beim Speichern bzw. Speichern&Schließen prüfen, ob referenzierte Dateien verändert wurden.
Wenn referenzierte Dateien verändert wurden erscheint ein Dialog mit weiteren Optionen.
inventor.script.shutdown Definiert eine ausführbare Datei die beim Beenden ausgeführt werden soll (z.B. .batch, .exe).
inventor.script.startup Definiert eine ausführbare Datei die beim Start ausgeführt werden soll (z.B. .batch, .exe).
inventor.standardfolder
inventor.variable.needprefix
inventor.variable.prefix
inventor.teamwork Definiert ob die Teamwork Funktion aktiv ist.
inventor.teamwork.checkinterval Zeitspanne (in Minuten) nach der geprüft wird, ob referenzierte Dateien nachgeladen werden müssen.
Standardwert=5