SOLIDWORKS

Die Integration von speedyPDM in SOLIDWORKS ® erfolgt als Zusatzanwendung (Addin).
Das speedyPDM Solidworks-Addin liefert neben den üblichen Menüs und Werkzeugkästen noch ein Rollup-Fenster oder alternativ ein Task-Fenster.

Rollup

Das Rollup–Fenster positioniert sich oberhalb der Titelleiste von Solidworks und klappt automatisch auf, wenn Sie den Mauszeiger über die Titelleiste bewegen.
Alternativ kann das Rollup-Fenster auch im Task-Fensterbereich dargestellt werden. Der Konfigurationsparamater [solidworks.rollup.dockable] steuert das Verhalten.

Wenn das Rollup-Fenster nicht im Task-Fensterbereich angeordnet ist klappt es automatisch wieder zu, wenn Sie in Solidworks arbeiten.

Das Rollup–Fenster hat einen ähnlichen Aufbau wie der speedy–Explorer mit Ausnahme der Navigationsleiste, die aus Platzgründen in Form einer Aufklappliste implementiert wurde.

Die Position der einzelnen Teilbereiche im Rollup-Fenster können manuell angepasst werden und werden per User gespeichert.

Im oberen Bereich des Rollup–Fensters befindet sich der Navigationsbereich in Form einer Aufklappleiste.
Die Bedienung ist ähnlich der Navigation in speedy-Explorer.

Navigation im Rollup-Fenster

Mit Klick auf das [-] oder [+] Symbol wird der entsprechende Baum geöffnet bzw. geschlossen.
Gleiches erreicht man mit Doppelklick auf das Ordner-Symbol.
Ein Doppelklick auf eine Verzeichniseintrag stellt das Arbeitsverzeichnis ein und schließt das Navigationsfenster.

Nach dem Anwählen eines Pfades werden im Hintergrund bereits die Dokumente angezeigt.

Rechts neben der Navigationsleiste finden befindet sich ein Werkzeugkasten zur Projekt- und Ordnerverwaltung:

SymbolBedeutung
In der Ordnerstruktur eine Ebene nach oben
Einen neuen Ordner anlegen.
Wenn in der Navigation das Schließfach aktiv ist wird ein neuer Projektordner angelegt.
Ist ein Projektordner oder ein anderer Ordner aktiv wird ein neuer Unterordner angelegt.
Ordnereigenschaften bearbeiten
Strukturansicht aktualisieren
Projektsichtbarkeit ein/aus.

Werkzeugleiste

SymbolBedeutung
Navigationshistorie zurück
Navigationshistorie vorwärts
Neues Dokument
Dokument öffnen (Modell oder Baugruppe)
Zeichnung öffnen
Dokument ablegen
Dokument freigeben
Dokument-Eigenschaften
Dokument ansehen
Dokument löschen
Ansicht aktualisieren
Dokument suchen
Benutzeroptionen

Die speedy Ribbon

Neues Dokument anlegen

Es stehen verschiedene Möglichkeiten zur Auswahl:

Solidworks:

  • Sie erstellen eine neue Datei mit dem Solidworks-Befehl Datei » Neu.
  • Sie erzeugen das Model oder die Baugruppe mit den üblichen Solidworks-Methoden.
  • Sie wählen den Solidworks-Befehl Datei » Speichern.
  • Der speedy-Dialog „Neues Dokument“ erscheint.
    Machen Sie Ihre Angaben für den neuen Artikel.

Rollup-Fenster:

  • Wählen Sie den Befehl „Neues Dokument“.
  • Der speedy-Dialog Neues Dokument erscheint.
    Machen Sie Ihre Angaben für den neuen Artikel.
    speedy legt ein neues Dokument an und erstellt eine leere Dokumentdatei anhand der Vorlage.
  • Der neue Artikel ist in der Dokumentenliste markiert.
  • Wählen Sie den Befehl „Dokument öffnen“.
  • Die leere Dokumentdatei wird geöffnet.

Dokument öffnen

Es stehen verschiedene Möglichkeiten zur Auswahl:

Solidworks:

  • Wählen Sie den Solidworks-Befehl Datei » Öffnen.
  • Der speedy-Dialog Datei öffnen wird angezeigt.
  • Wählen Sie das gewünschte Dokument aus und bestätigen Sie den Dialog mit Öffnen.

Rollup-Fenster:

  • Suchen Sie das zu öffnende Dokument.
  • Wählen Sie den Befehl „Dokument öffnen“.

Zeichnungen öffnen

Menü speedy » Zeichnung öffnen
Kontextmenü Baugruppe » Zeichnung öffnen
Werkzeugkasten Zeichnung öffnen

Öffnet die Zeichnung zu dem aktuell geöffneten Model (Teil/Baugruppe). Wenn noch keine Zeichnung existiert wird automatisch eine Zeichnung anhand der Vorlagen, die in der Teileart definiert sind, erzeugt und geöffnet. Enthält die Zeichnungsvorlage bereits vordefinierte Ansichten werden diese automatisch mit dem Model gefüllt.

Komponente öffnen

Menü speedy » Teil/Baugruppe öffnen
Kontextmenü Baugruppe » Teil/Baugruppe öffnen
Werkzeugkasten Komponente öffnen

Wenn Sie eine Baugruppe geöffnet haben und das Model eine Komponente oder eine Unterbaugruppe zum bearbeiten öffnen möchten müssen Sie den speedy Befehl Teil/Baugruppe öffnen verwenden. Teile und Unterbaugruppen werden beim Öffnen einer Baugruppe nur im schreibgeschützten Modus geladen, um unnötiges entnehmen aus der speedy – Datenbank und unbeabsichtigtes verändern zu verhindern. Wenn Sie also den Solidworks - Befehl zum Öffnen von Teilen verwenden, werden diese schreibgeschützt geöffnet.

Komponentenzeichnung öffnen

Menü speedy » Bauteilzeichnung öffnen
Kontextmenü Baugruppe » Bauteilzeichnung öffnen

Öffnet die Zeichnungsdatei der gewählten Komponente.

Komponente einfügen

Sie haben eine Baugruppe geöffnet und möchten ein bestehendes Teil oder eine andere Baugruppe einfügen. Es stehen Ihnen verschiedene Möglichkeiten zur Auswahl:

Solidworks:

  • Wählen Sie den Solidworks-Befehl Einfügen » Komponente » Bestehendes Teil/Baugruppe.
  • Wählen Sie die Schaltfläche DURCHSUCHEN.
  • Der speedy-Dialog Datei öffnen wird angezeigt.
  • Wählen Sie das gewünschte Dokument aus und bestätigen Sie den Dialog mit ÖFFNEN.

Rollup-Fenster:

  • Suchen Sie das zu öffnende Dokument.
  • Markieren Sie das Dokument in der Dokumentliste
  • Ziehen Sie mit gedrückter linker Maustaste in den Zeichenbereich von Solidworks (Drag & Drop).
  • Das Teil oder die Baugruppe, die mit dem Dokument verknüpft ist wird in die aktuelle Baugruppe eingefügt und „hängt“ am Mauszeiger.

Wenn das Dokument Konfigurationen enthält oder ein Variantenteil ist erscheint nach dem Einfügen der Dialog Variante bearbeiten.

Speichern

Beim Speichern von Baugruppen wird überprüft, ob die Baugruppe noch Teile oder Unterbaugruppen enthält, die nicht dem aktuellen Projekt angehören.

Die Hinweismeldung kann nur mit OK bestätigt werden. Die Datei wird aber auf jeden Fall gespeichert. Verwenden Sie den Befehl Komponente umbenennen, um projektfremde Teile umzubenennen.

Wird die aktuelle Datei mehrfach verwendet erscheint beim Speichern ebenfalls ein Hinweisfenster:

Sie haben nun die Möglichkeit die Datei unter einer neuen Artikelnummer abzulegen oder unter gleichem Namen zu speichern.

Speichern und Schließen

Zum Schließen eines in speedy verwalteten Dokuments sollten Sie den Befehl Speichern+Schließen aus dem speedy–Menü oder dem speedy–Werkzeugkasten wählen.

Menü speedy » Speichern+Schließen
Ribbon speedy » Speichern+Schließen

Das Modell wird in das Fenster gezoomt und eine Isometrische Ansicht eingestellt, um eine aussagekräftige Dateivorschau zur Verfügung zu erhalten, anschließend wird die Datei gespeichert und geschlossen.

Komponente kopieren und ersetzen

Menü speedy » Komponente kopieren und ersetzen
Kontextmenü Baugruppe » Komponente kopieren und ersetzen

Dient zum Ersetzen von projektfremden Bauteilen.

Bedeutung der Eingabefelder

Bauteile Liste der ausgewählten Komponenten
Automatisch wählen Sucht alle Komponenten in der 1. Ebene, die ersetzt werden müssen.
Nur ausgewählte Komponenten ersetzen Ersetzt nur die ausgewählten Komponenten.
Komplette Struktur ersetzen Ersetzt die ausgewählten Komponenten und Ihre Unterbaugruppen und Unterkomponenten.

Wenn Sie die Eigenschaftenseite mit OK bestätigen arbeitet speedy die gewählten Komponenten der Reihe nach ab und kopiert und ersetzt sie anschließend. Hierzu erscheint für jede Komponente der speedy–Dialog [Neues Dokument], in dem Sie den Dokumentnamen definieren. Bevor der Dialog erscheint untersucht speedy die Solidworks–Datei auf definierte Eigenschaften und füllt je nach Erkennungsgrad den Dokumenttyp, die Benennung und den Lieferanten bereits aus.

Wenn die Option „Nur ausgewählte Komponenten ersetzen“ gewählt wurde und es sich um ein bereits verwaltetes speedy-Dokument handelt wird automatisch eine neue Nummer vergeben. Das neue Dokument wird im Ordner der aktuellen Baugruppe erstellt. Es erscheint in diesem Fall kein Neu-Dialog.

Komplette Struktur ersetzen:
Wenn Sie die Option Komplette Struktur ersetzen gewählt haben erscheint folgender Dialog:

Der Dialog zeigt die komplette Baugruppenstruktur und alle zugehörigen Dateien.

Die Baumstruktur unterscheidet in der Anzeige folgende Merkmale:

  • Einträge in grüner Schrift stellen ein bereits bekanntes speedy-Dokument dar.
  • Einträge in blauer Schrift stellen eine unbekannte lokale Datei dar.
  • Einträge in roter Schrift stellen eine nicht vorhandene Datei dar.
  • Einträge in grauer Schrift stellen eine zusätzliche gleichbenannte Datei zu einem Haupteintrag dar.
  • Fett geschriebene Einträge sind Haupteinträge zu denen es evtl. noch weitere gleichbenannte Dateien gibt.

Kaufteile/U-Teile

Häufig müssen Kauf-, Norm- oder Kundenteile mit Hilfe einer Baugruppendatei (Assembly) und mehrerer Teiledateien (Parts) beschrieben werden. Ein typischen Beispiel ist ein Pneumatik-Zylinder. Damit Bewegung oder verschiedene Einbauzustände benutzt werden können muss eine Baugruppendatei mit entsprechenden Teiledateien konstruiert werden. Seitens der Verwaltung interessiert aber nur der Zylinder als ganzer.
Hierzu werden entweder alle Dokumenttypen, die keine Stückliste haben als „Teile“-Dokumenttyp behandelt oder mit dem Konfigurationsparameter [inventor.partrename.partdoctypes] werden die Dokumenttypen aufgezählt.

Wenn nun in Solidworks eine Baugruppendatei in speedy abgelegt wird und im Neu-Dialog ein „Teile-„Dokumenttyp gewählt werden alle Komponenten automatisch als U-Teile abgelegt:

Kaufteil-Zylinder mit U-Teilen


Weitere U-Teile hinzufügen
Wenn Sie einem vorhandenen Kaufteil weitere U-Teile hinzufügen möchten fügen Sie der Solidworks Baugruppe die Komponente mit den üblichen Mitteln hinzu. Nun verwenden Sie den speedy Befehl „Komponente kopiern und ersetzen“.

Wählen Sie die Komponente aus und markieren sie „Nur ausgewählte Komponenten kopieren und ersetzen“.
Die Komponente wird nun automatisch dem speedy-Dokument als U-Teil hinzugefügt und entsprechend umbenannt.

U-Teile ersetzen
Wenn Sie bei einem vorhandenen Kaufteil bestimmte U-Teile austauschen müssen öffnen Sie die Solidworks Baugruppe zur Bearbeitung.
Tauschen Sie nun die gewünschten U-Teile durch die neuen Komponenten aus.
Nun verwenden Sie den speedy Befehl „Komponente kopieren und ersetzen“.
Wählen Sie die Komponente aus und markieren Sie sonst nichts im Dialog.
Die Komponente wird nun automatisch dem speedy-Dokument als U-Teil hinzugefügt und entsprechend umbenannt.

Komponente durch aktuelle Version ersetzen

Ersetzt die ausgewählte Komponente durch die aktuellste Version des Artikels.

Teilverwendung

Zeigt die Teileverwendung der aktuellen Datei oder der markierten Komponente an.

Referenz-Manager

Öffnet den Referenz-Manager für die aktuelle Baugruppendatei (siehe auch Referenz-Manager)

Spiegeln

speedyPDM unterstützt beim Spiegeln von einzelnen Teilen wie auch Baugruppen. speedyPDM greift dabei in den Speichern-Dialog von Solidworks ein.

Verwenden Sie die bekannten Mechanismen zum Spiegeln von Teilen oder Baugruppen in Solidworks:

Für das gespiegelte Teil wird ebenfalls ein Artikel in speedy erstellt.
Das gespiegelte Teil ist mit dem Ursprungsteil in speedy verknüpft (Relation MIRRORED).
Dadurch ist sichergestellt, dass bei der Freigabe des Ursprungsteils auch das gespiegelte Teil freigegeben wird.

Freigabe von gespiegelten Teilen
Bitte beachten Sie:
Wenn ein Ursprungsteil geändert wird, wird auch das gespiegelte Teil in Arbeit genommen.
Damit die Änderungen auch im gespiegelten Teil übernommen werden sollten Sie das gespiegelte ebenfalls öffnen.
Durch die Freigabe eines gespiegelten Teils wird das Ursprungsteil nicht freigegeben.
Gespiegelte sollten nicht direkt freigegeben werden. Geben Sie immer nur das Ursprungsteil frei.

Stückliste bearbeiten

Öffnet den Stücklistendialog mit der aktuellen Baugruppen-Stückliste.
Wenn noch keine Stückliste vorhanden ist, wird die Stückliste automatisch erstellt.
Menü speedy » Stückliste bearbeiten
Werkzeugkasten Stückliste bearbeiten
Kontextmenü Baugruppe » Stückliste bearbeiten

Zur Aktualisierung der speedy Stückliste wird die Solidworks Baugruppe analysiert.

Hierbei werden folgende Solidworks Einstellungen beachtet:

  • Unterdrückte Komponenten werden nicht in die Stückliste aufgenommen.
  • Komponenten, die in einem definierten Feature-Ordner liegen, werden nicht in die Stückliste aufgenommen. Administrativ können Namen für Feature-Ordner festgelegt werden, die von der Stückliste ausgeschlossen sind.
  • Komponenteneigenschaft „Aus Stückliste ausschließen“.
  • Konfigurationseigenschaft „Kind-Komponenten in Stücklisten nicht anzeigen, wenn als Unterbaugruppe verwendet.

Baugruppe und Zeichnung geöffnet:
Wenn Sie die Baugruppe und die zugehörige Zeichnung geöffnet haben müssen Sie nach Änderungen in der Baugruppe speichern bevor Sie in die Zeichnung wechseln.
Beim Speichern wird die speedy Stückliste aktualisiert. Damit ist sichergestellt, dass Stücklistenänderungen sofort in der Zeichnung sichtbar werden.

Stücklistenposition suchen

Suche einen Artikel anhand der Positionsnummer oder der Dokument-Nummer.

Text einfügen

Fügt einen Text in eine Zeichnung ein, der beim Sprache umschalten entsprechend der Übersetzung ersetzt wird.

Sprache umschalten

Schaltet die Sprache, entsprechend der eingestellten Projektsprache, in der Zeichnung um.
Die Texte im Schriftkopf sowie manuell eingefügte Texte werden umgeschaltet.
In den Projekteinstellungen definierte kundespezifische Schriftköpfe werden ebenfalls getauscht.

Komponente fixieren

Verschiebt die gewählte Komponente in den Baugruppen Ursprung und fixiert sie dort.

Variante auswählen/bearbeiten

Im Dialog Variante auswählen können Sie eine vorhandene Solidworks Konfiguration auswählen oder wenn der Artikel ein Variantenartikel ist auch eine neue Variante erstellen.
Menü speedy » Variante bearbeiten
Werkzeugkasten Variante bearbeiten
Kontextmenü Teil/Baugruppe » Variante bearbeiten

Neue Variante erstellen:
Zum erstellen einer neuen Variante markieren Sie den Eintrag „Neue Variante“ in der Liste oder klicken Sie die Schaltfläche. In der Variablenliste sind nun alle Variantenvariablen in der Spalte Wert mit “???“ gefüllt. Definieren Sie die jeweiligen Variablenwerte. Wenn Sie die letzte Variable angegeben haben sucht speedy, ob bereits eine Variante mit den eingegebenen Werten vorhanden ist und markiert diese ansonsten wird eine neue Variante mit den Werten erzeugt.

Speichern als

Speichert die aktive Datei in einem zusätzlichen Dateiformat ab.
Die Zusatzdatei wird mit gleichen Dateinamen im gleichen Verzeichnis wie die aktuelle Datei abgelegt. Je nach geöffnetem Dateityp (sldprt, sldasm, smddrw) stehen ihnen unterschiedliche Speicherformate zur Verfügung.

Benutzeroptionen

Öffnet den Dialog zur Bearbeitung der Benutzeroptionen.

Meldungen/Fehler/Warnungen zurücksetzen

Einige Warnhinweise, Fehlermeldungen und Benutzerabfragen können durch Auswahl einer Option „Diese Frage nicht nochmal stellen“ oder „Diesen Hinweis nicht nochmal melden“ im Dialog der Meldung deaktiviert werden. Diese deaktivierten Meldungen können mit Hilfe dieses Befehls wieder aktiviert werden. Es erscheint ein Dialog mit allen deaktivierten Meldungen. Markieren Sie alle Meldungen, die wieder aktiviert, also beim nächsten vorkommen wieder erscheinen sollen und bestätigen den Dialog mit OK.

Material / Masseneigenschaften

Material kann von speedy bidirektional ausgetauscht werden.
Die Masseneigenschaften (Gewicht, Volumen, …) werden im Normalfall nur von speedy gelesen. Eine Ausnahme stellt das Gewicht dar.

Fall 1:

  • Die Masseneigenschaften werden von Solidworks automatisch ermittelt, abhängig vom Material bzw. dessen Dichte.
  • In speedy ist die Artikeleigenschaft GEWICHT schreibgeschützt.
  • ⇒ Das Gewicht wird vom CAD Modell eingelesen und im Artikelstamm gespeichert.

Fall 2:

  • Die Artikeleigenschaft GEWICHT ist nicht schreibgeschützt.
  • Es ist kein Material im Artikelstamm defineirt.
  • ⇒ Das Gewicht wird von speedy an das Modell übertragen und die Eigenschaft „Masseneigenschaften überschreiben“ wird gesetzt.

Fall 3:

  • Die Artikeleigenschaft GEWICHT ist nicht schreibgeschützt.
  • Es ist ein Material im Artikelstamm definiert.
  • ⇒ Das Gewicht wird vom Modell in den Artikelstamm eingelesen.
  • ⇒ Wenn das Gewicht in speedy manuell geändert wird, wird dies in das Modell übertragen. Die Eigenschaft „Masseneigenschaften überschreiben“ wird gesetzt.
  • ⇒ Ändert sich das Material in speedy wird die Eigenschaft „Masseneigenschaften überschreiben“ wieder deaktiviert und Solidworks berechnet wieder automatisch.

Installation

Systemvoraussetzungen

Für folgende SOLIDWORKS Versionen steht ein Addin zu verfügung:

SOLIDWORKS Version speedy Addin
SOLIDWORKS 2016 swxSpeedy72016.dll (x64) (Support endet 2020)
SOLIDWORKS 2017 swxSpeedy72017.dll (x64) (Support endet 2021)
SOLIDWORKS 2018 swxSpeedy72018.dll (x64) (Support endet 2022)
SOLIDWORKS 2019 swxSpeedy72019.dll (x64)
SOLIDWORKS 2020 swxSpeedy72020.dll (x64)
SOLIDWORKS 2021 swxSpeedy72021.dll (x64)
SOLIDWORKS 2022 swxSpeedy72022.dll (x64) (comming soon)

Zusatzanwendung registrieren

Zur Registrierung der Zusatzanwendung in Solidworks benötigen Sie administrative Rechte.
Seit Windows 7 sollten Sie beachten, dass beim Ausführen von Befehlen „Als Administrator“ normalerweise die verknüpften Netzlaufwerke nicht verfügbar sind. Verweise auf Dateien müssen immer per UNC-Angabe (\\servername\freigabe\...) erfolgen.

Variante 1: Innerhalb von Solidworks

Sie haben administrative Rechte auf dem Arbeitsplatzrechner. Starten Sie Solidworks und wählen den Befehl „Datei öffnen“. Setzen Sie im Öffnen Dialog den Dateityp-Filter „Add-Ins (*.dll) und wählen die Datei swxSpeedy72017.dll im speedy Verzeichnis aus.

Beachten Sie das bei 32 Bit Solidworks die Add-In Datei aus dem speedy Verzeichnis bin32 zu wählen ist und bei 64 Bit Solidworks aus dem bin64 Verzeichnis zu wählen ist.
Wenn die Registrierung erfolgreich war fordert entweder speedy direkt zum Login auf oder muss noch in der Liste der Zusatzanwendungen aktiviert werden.

Variante 2: Manuell

Sollten alle o.g. Varianten nicht funktionieren sollte die Registrierung per Konsole erfolgen. Hierzu muss ein Konsolenfenster „Als Administrator“ ausgeführt werden.

Im Konsolenfenster führen Sie die Registrierung mit Übergabe des Add-In Moduls aus.

regsvr32.exe  \\<server>\speedy_bin$\bin64\swxSpeedy72018.dll 
oder
regsvr32.exe \\<server>\speedy_bin$\bin32\swxSpeedy72018.dll


Variante 3: Batchdatei

Starten Sie je nach Betriebssystem die Batchdatei register_solidworks.cmd im speedy Programmverzeichnis (bin32 oder bin64). Das Solidworks Add-In wird beim Betriebssystem registriert. Ab Windows 7 sollten Sie die Batchdatei „Als Administrator ausführen“.

Administration

Dateieigenschaften

Die Zuordnung von speedy/PDM Dokumenteigenschaften zu Dateieigenschaften erfolgt mit Hilfe einer Konfigurations- und Zuordnungsdateien (siehe hierzu auch Konfiguration).

Zuordnung der Dokumenteigenschaften zu Dateieigenschaften

Zuordnung der Dokumenteigenschaften zu Dateieigenschaften erfolgt in der Konfigurationsdatei swxSpeedy.ini.

Toolbox-Teile in Stücklisten

Zuordnung der Dateieigenschaften von Toolbox-Teilen zu Stücklisteneigenschaften erfolgt in der Konfigurationsdatei swxToolbox.ini. Werden Toolbox-Teile nicht in speedy verwaltet muss eine Zuordnung der Dateieigenschaften zu speedy Eigenschaften erfolgen damit die Toolbox-Teile in der speedy Stückliste erfasst werden können. Damit ein Toolbox-Teil aus Solidworks auch in speedy übernommen wird muss die Position entweder bereits ein verwaltetes Dokument sein oder eine Eigenschaft als Dokumentnummer (dm_docno) zugeordnet werden.

Folgende besondere Eigenschaften stehen zur Verfügung:

swx.partnumber Entweder die erkannte Dokumentnummer (dm_docno) weil die Komponente bereits verwaltet wird oder Dateiname der Komponente.
swx.component.name Name der Komponente
swx.component.title Dateiname der Komponente
swx.component.reference Refrenzwert der Komponente
swx.configuration.name Konfigurationsname der Komponente
swx.configuration.comment Kommentar der Konfiguration der Komponente
swx.configuration.alternatename Alternativer Name der Konfiguration
swx.configuration.usealternatename Alternativen Namen verwenden Ja/Nein
[ATTRIBUTE_MAP]
dm_docno  = "swx.configuration.name"
BEN1      = "swx.component.title"

Zuschnittliste als Stückliste

Die Zuordnung der Eigenschaften aus der Zuschnittliste von Schweißteilen zu Stücklisteneigenschaften erfolgt in der Datei swxWeldment.ini.

[ATTRIBUTE_MAP]
dm_docno          = "BESCHREIBUNG"
BEN1              = "Beschreibung"
LÄNGE             = "LÄNGE"
WINKEL1           = "WINKEL1"
WINKEL2           = "WINKEL2"
MATERIAL          = "MATERIAL"

Konfigurationsparameter

solidworks.
SchlüsselBeschreibung
solidworks.autoset.colorDie am Material (Klasse) eingestellte Farbe wird dem SWX-Body gesetzt.
solidworks.autoset.hatchDie am Material eingestellte Schraffur wird dem Part zugeordnet.
solidworks.autoset.materialDefiniert ob beim Öffnen automatisch das Material gesetzt werden soll
solidworks.bomposition.deletenothandledDefiniert ob Stücklistensymbole von nicht definierten Positionen gelöscht werden sollen. Es erfolgt eine Benutzerabfrage vor dem Löschen.
solidworks.bomposition.autodeletenothandledDefiniert ob Balloons die nicht in der Stückliste vorhanden sind automatisch gelöscht werden.
solidworks.bomtable.autocreate Definiert, ob speedy automatisch eine Stückliste beim Speichern erstellen soll.
solidworks.bomtable.autoinsert Definiert, ob automatisch eine (unsichtbare) Stückliste in Solidworkszeichnungen eingefügt wird.
solidworks.bomtable.autosave Alle Änderungen werden automatisch gespeichert.
solidworks.bomtable.autosorted Die Stückliste wird immer automatisch sortiert.
solidworks.bomtable.autofreepos Anzahl an freien Positionen zwischen den einzelnen Sortierkriterien.
solidworks.bomtable.comparereference Beim Einsammeln der Komponenten die Komponenten-Referenz ebenfalls zum Auffinden gleicher Positionen heranziehen.
Standardwert:=0
solidworks.bomtable.configignore Definiert ob Stücklisten aktualisiert werden wenn nicht die erste Konfiguration aktiv ist bzw. bei Variantenbaugruppen eine abgeleitete Konfiguration aktiv ist.
0 := Stücklisten werden nur aktualisiert wenn die erste Konfiguration aktiv ist. Es wird nicht aktualisert, wenn eine abgeleitete Konfiguration aktiv ist.
1 := Stücklisten werden immer aktualisiert.
solidworks.bomtable.featuresorted Sortierung der Stückliste entspricht der Reihenfolge im Featurebaum der Baugruppe. Es erfolgt keine automatische Sortierung.
solidworks.bomtable.hiddenDefiniert ob in SolidWorks eine Stückliste unsichtbar sein soll oder nicht
solidworks.bomtable.bomtypeStücklistentyp der Solidworks Stückliste
1 := Nur Einzelteile in die Stückliste einfügen
2 := Nur die oberste Ebene
3 := Stückliste mit Einrückung
siehe auch [solidworks.bomtable.showchildcomponents]
solidworks.bomtable.indentednumberingtype Art der Nummerierung bei eingerückten Stücklisten
solidworks.bomtable.detailedcutlist Zeigt detailierte Zuschnittslisten bei eingerückten Stücklisten an.
solidworks.bomtable.anchortypeStücklistenankerpunkt
1 := Links oben
2 := Rechts oben
3 := Links unten
4 := Rechts unten
solidworks.bomtable.useranchorpointDefiniert ob ein Ankerpunkt im Zeichnungsrahmen verwendet werden soll oder die angegebenen Einfügekoordinaten.
solidworks.bomtable.insertpointxEinfügepunkt für „unsichtbare“ Stückliste.
solidworks.bomtable.insertpointyEinfügepunkt für „unsichtbare“ Stückliste.
solidworks.bomtable.includehiddenUnsichtbare Teile in SolidWorks auch in die Stückliste einfügen; wenn nicht definiert wird bom.includehidden verwendet.
solidworks.bomtable.includesuppressedUnterdrückte Teile in SolidWorks auch in die Stückliste einfügen; wenn nicht definiert wird bom.includesuppressed verwendet
solidworks.bomtable.folderignoreDefiniert ob die Komponenten (siehe solidworks.bomtable.foldernames) bei der Stücklistenermittlung ignoriert werden.
solidworks.bomtable.foldernamesKomponenten, die einem Feature-Ordner zugeordnet wurden werden nicht in die Stückliste aufgenommen, wenn der Ordnername in der Liste definiert wurde. Durch Semikolon getrennte Aufzählung der Ordnernamen.
solidworks.bomtable.pathnamesKomponenten, die aus einem der angegebenen Verzeichnisse stammen werden nicht in die Stückliste aufgenommen.
solidworks.bomtable.pathignoreDefiniert, ob die Komponenten (siehe solidworks.bomtable.pathnames) bei der Stücklistenermittlung ignoriert werden.
solidworks.bomtable.showchildcomponentsGibt an ob beim Ermitteln der SolidWorks Stückliste die Kindkomponenten überhaupt beachtet werden sollen.
Wenn der Parameter gesetzt ist wird die Stücklistentabelle in der Zeichnung immer mit der Option „Nur Teile“ erstellt. siehe auch [solidworks.bomtable.bomtype]
solidworks.bomtable.updateconfigurations Definiert, ob beim Aktualisieren der Stückliste diese für alle Konfigurationen aktualisiert oder nur für die Aktuelle.
solidworks.bomtable.unitcheck Beim aufsummieren von Stücklistenpositionen (Komponenten) die Einheit des jew. Ist die dem Artikel zugeordnete Einheit nicht zum Summieren aktiviert werden die Stücklistenpositione ebenfalls nicht summiert, d.h. jede Komponente erhält eine eigene Position in der Stückliste.
Siehe Auch [document.property.unit] bzw. [solidworks.variable.quantity]
solidworks.bomtable.summarize Stücklistenpositionen beim Einlesen der Komponenten aufsummieren.
Standardwert:=1
solidworks.bomtable.templateVorlage der unsichtbaren Solidworks Stückliste
solidworks.bomtable.traverschildcomponentsDefiniert ob Unterbaugruppen mit in die Stückliste übernommen werden .
solidworks.bomtable.useranchorpointDefiniert ob ein Ankerpunkt im Zeichnungsrahmen verwendet werden soll oder die angegebenen Einfügekoordinaten.
solidworks.checkin.firstsheet Beim einchecken einer Zeichnung immer das 1. Blatt aktivieren.
solidworks.checkin.forcesaveGibt an das beim Speichern + Schließen ein Speichern erzwungen wird, unabhängig davon ob etwas geändert wurde oder nicht
solidworks.checkin.shownamedviewStandardansichten beim Speichern
1 := Vorderseite
2 := Rückseite
3 := Links
4 := Rechts
5 := Oben
6 := Unten
7 := Isometrisch
8 := Trimetrisch
9 := Dimetrisch
solidworks.checkin.zoomtofit Beim Speichern&Schließen Ansicht zoomen.
solidworks.clipboard.extension
solidworks.clipboard.previewsize
solidworks.combinebom.headheight??
solidworks.combinebom.rowheight??
solidworks.component.attachinvisble Steuert das Verhalten von speedy bei Solidworksdateien, die aktuell kein eigenes Bearbeitungsfenster haben.
Bei aktiviertem Konfigurationsparameter:
- speedy verbindet sich bereits beim Öffnen auch mit im Hintergrund geladenen Komponenten von Baugruppen.
- Nach dem Bearbeiten von Unterteilen/-baugruppen werden diese nicht automatisch wieder eingecheckt.
Bei deaktiviertem Konfigurationsparameter:
- Nach dem Bearbeiten von Unterteilen/-baugruppen werden diese automatisch wieder eingecheckt.

Für den Fall, dass beim Auschecken von Elterndokumenten auch die Kinddokumente ausgecheckt werden sollen (Relationstyp: COMPONENT) ist der Parameter automatisch aktiv.
Standardwert := 0
solidworks.component.handledimchangeDefiniert ob nach einer Maßänderung ausgecheckt wird.
solidworks.component.handlestatechangeÜberwachung der Statusänderung von reduziert auf vollständig bzw. umgekehrt bewirkt ein auschecken bzw. einchecken.
solidworks.configignore Definiert ob Dateieigenschaften, Masseeigenschaften und Abmessungen aktualisiert werden wenn nicht die erste Konfiguration aktiv ist bzw. bei Variantenbaugruppen eine abgeleitete Konfiguration aktiv ist.
0 := Eigenschaften werden nur aktualisiert wenn die erste Konfiguration aktiv ist. Es wird nicht aktualisert, wenn eine abgeleitete Konfiguration aktiv ist.
1 := Eigenschaften werden immer aktualisiert.
solidworks.configuration.alldimensionDefiniert ob beim einlesen der Bemaßungen einer Konfiguration alle Bemaßungen eingelesen werden sollen oder nur die Konfigurationsspezifischen
solidworks.configuration.createchildsDefiniert ob beim erstellen einer neuen Konfiguration abgeleitete Konfigurationen automatisch erstell werden sollen.
solidworks.configuration.dlgline1Definiert den Inhalt der 1. Zeile des Konfigurationsassistenten.
solidworks.configuration.dlgline2Definiert den Inhalt der 2. Zeile des Konfigurationsassistenten
solidworks.configuration.dlgline2.jpg
solidworks.configuration.forceupdateDefiniert ob das aktualisieren der Variantenliste beim Speichern erzwungen wird.
solidworks.configuration.purgereleased Bei bereits zuvor freigegebenen Artikeln nichth mehr benötigte Varianten löschen.
solidworks.configuration.optionsKonfigurationsoptionen beim Erstellen einer neuen Konfiguration
1 := Alternativen Namen verwenden
2 := Keine Teile in der Stückliste anzeigen
4 := Standardmäßig unterdrückt
8 := Standardmäßig unsichtbar
16 := Minimum Feature Manager
32 := Eigenschaften erben
64 := Link zu den Eltern
siehe SolidWorks Add-Ins API Hilfe (swConfigurationOptions2_e)
solidworks.configuration.prefixVorsilbe die beim Erstellen dem Konfigurationsnamen vorangestellt wird bzw. bei einer ungesteuerten Variante vorangestellt sein muss damit diese von speedy übernommen wird.
solidworks.configuration.previewDateiendung für die Standardvorschau im Konfigurationsdialog
solidworks.configuration.property.delete Definiert, ob bei nicht Variantenteilen die konfigurationsspezifischen Eigenschaften gelöscht werden.
solidworks.configuration.property.import Konfigurationsspezifische Eigenschaften der aktiven Konfiguration beim Importieren ebenfalls einlesen.
solidworks.configuration.releasedDefiniert, ob bei freigegebenen Varianten ohne erneute Freigabe eine neue Variante erstellt werden kann.
Bei aktiviertem Konfigurationsparameter wird im Hintergrund der Schreibschutz der Freigabe aufgehoben, die Variante erstellt und anschließend wieder der Schreibschutz gesetzt.
Bei deaktiviertem Konfigurationsparameter wird der Artikel ausgecheckt, die Variante erstellt und anschließend die Freigabe wieder erteilt.
solidworks.configuration.useoptions Im Dialog „Variante wählen“ die Auswahl-Option anbieten, die es ermöglicht zu definieren, ob Änderungen nur auf diese oder alle Konfigurationen wirken.
solidworks.documentlist.coldescnameStandardspaltenbeschreibung für Dokumentenliste im Rollup
solidworks.disolvesubassemblyEine Baugruppe wird nach dem Drag & Drop automatisch aufgelöst, wenn die Artikelnummer mit der definierten Bezeichnung endet (Suffix).
solidworks.drawingreferencecheck Prüft, ob die Modellrefernzen auf dem 1.Blatt einer Zeichnung auf das gleichnamige Modell verweisen.
solidworks.dropcreatenew.classification
solidworks.dropcreatenew.deleteconfigurationWenn bei Drag and Drop spezifiziert wird das die gewählte Variante als neues Dokument erstellt wird dann besagt der Schalter das alle anderen Konfigurationen gelöscht werden.
solidworks.dropcreatenew.doctypeStandarddokumenttyp wenn ein neues Dokument beim Drag & Drop erstellt wird.
solidworks.dropcreatenew.editobjectDefiniert ob Dokumenteigenschaften nach dem erstellen bearbeitet werden sollen.
solidworks.dropcreatenew.renameconfigurationDefiniert wenn beim Drag and Drop ein neues Dokument erstellt wird ob verbleibende bzw. aktive Konfigurationen umbenannt werden sollen.
solidworks.dropcreatenew.specialpartDefiniert wenn man ein Teil per Drag and Drop in eine geöffnete Baugruppe einfügt ob der Haken ’Als Entwurfsteil einfügen’ aktiv ist
solidworks.dropcreatenew.specialpart.jpg
solidworks.dropcreatenew.manual
solidworks.extensionsListe der gültigen SolidWorks Dateierweiterungen Optional.
solidworks.filedrop.react Aktiviert/Deaktiviert die Reaktion von speedy auf das Einfügen von Komponenten in eine Baugruppe.Standardwert:=1
solidworks.filedrop.useversionVerhalten beim Einfügen eines freigegebenen Modells in eine Baugruppe:
0 := Nachfragen (Standard)
1 := Immer aktuellste Version einfügen.
2 := Freigegebene Version des Dokuments einfügen.
solidworks.filedrop.ExcludeFromBOM Ist für den Dokumenttyp des eingefügten Artikels „Nicht in Stückliste einfügen“ definiert, wird die Komponente in Solidworks ebenfalls von der Stückliste ausgeschlossen. Damit erscheint die Komponente auch nicht mehr in der Solidworksstückliste.
solidworks.import.cadenas
solidworks.langtext.balloonsizeBalloongröße in den Zeichnungen
0 := Engste
1 := 1 Zeichen
2 := 2 Zeichen
3 := 3 Zeichen
4 := 4 Zeichen
5 := 5 Zeichen
solidworks.langtext.balloonstyleBalloon Stil
0 := Nichts
1 := Rundschreiben
2 := Dreieck
3 := Sechskant
4 := Box
5 := Diamant
6 := Kreisspalt
7 := Pentagon
8 := Fahnen Pentagon
9 := Fahnen Dreieck
10 := Unterstrichen
solidworks.material.databaseDateiname der SolidWorks Materialdatenbank (inkl. Pfad)
solidworks.material.synchronize Das Zurückschreiben von Material in die Artikeleigenschaften kann gesteuert werden.
1 := Material wird zurück geschrieben (Standard)
0 := Material wird nicht zurück geschrieben.
solidworks.mirrornameAuflistung von Bezeichnungen die SolidWorks verwendet wenn Teile gespiegelt werden. (z.B. mirror;spiegeln)
solidworks.multipleuse.onsavecheckPrüfung auf Mehrfachverwendung beim speichern:
0 := nicht prüfen
1 := Warnen und User Befragen
2 := Automatisch als neues Teil/Baugruppe abspeichern
3 := Warnen und User Befragen,
wenn Antwort „trotzdem speichern“ nichts tun sonst automatisch als neues Teil/Baugruppe abspeichern
solidworks.multipleuse.savesilent???
solidworks.partrename.oninsertDefiniert ob beim Einfügen eines projektfremden Teils in eine Baugruppe unnummeriert werden soll.
solidworks.partrename.autoondropBeim Drag & Drop projektfremde Teile automatisch umnummerieren.
solidworks.partrename.completestructDefiniert ob beim umnummerieren von Komponenten auch die gesamte Struktur der Unterbaugruppen abgearbeitet werden soll.
solidworks.partrename.folderignore Definiert ob Komponenten, die Feature-Ordnern zugeordnet wurden (siehe solidworks.partrename.foldernames), bei der Ermittlung projektfremder Teile ignoriert werden sollen.
solidworks.partrename.foldernames Komponenten, die einem Feature-Ordner zugeordnet wurden werden bei der Ermittlung projektfremder Teile ignoriert. Durch Semikolon getrennte Aufzählung der Ordnernamen.
solidworks.partrename.oninsert Definiert, ob die Ermittlung projektfremder Teile bei jedem Einfügen einer Komponenten ausgeführt werden soll.
solidworks.partrename.partdoctypes Aufzählung von Dokumenttypen, die als Einzelteile zu interpretieren sind, wenn es darum geht zu entscheiden, ob U-Teile erstellt werden.
Bei leerem Parameter werden alle Dokumenttypen als Teile-Dokumenttyp verwendet, für die keine Stückliste definiert wurde.
solidworks.partrename.pathignore Definiert ob beim Ermitteln projektfremder Teile Komponenten in definerten Verzeichnissen (siehe solidworks.partrename.pathnames) ignoriert werden sollen.
solidworks.partrename.pathnames Definiert die Verzeichnisse die beim Ermitteln projektfremder Teile ignoriert werden sollen. Durch Semikolon getrennte Aufzählung von Verzeichnissen.
solidworks.partrename.silent??
solidworks.path.currentdirectoryDefiniert den Pfad der eingestellt ist wenn der User beim Speichern unter oder Öffnen lokal speichern wählt (Standardpfad für SolidWorks Dateien).
ACHTUNG: Dies hat keine Auswirkung auf den aktuellen Pfad beim „Speichern unter“ von bereits in speedy verwalteten Dateien (systembedingt).
solidworks.path.sheetformatSuchpfad der SolidWorks Blattformate. Ist dieser Pfad gesetzt wird beim Start von Solidworks automatisch der Solidworks Suchpfad für die Blattformate auf diesen Pfad umgestellt.
solidworks.preference.extrefnopromptorsave Siehe auch Solidworks API Help.
„Specifies whether to close read-only reference documents without prompting or attempting to save changes made to them when saving or closing the parent document.“
solidworks.preference.extrefopenreadonly Siehe auch Solidworks API Help.
„Specifies whether to open referenced documents as read-only.“
Damit dies funktioniert darf beim Eigenschaftenformat der Schalter Auschecken des Elterndokuments erfordert auschecken des Kind-Komponents nicht gesetzt sein.
solidworks.preference.extrefupdatecompnames Siehe auch Solidworks API Help.
„Specifies whether to mate to read-only parts using internal face IDs of the parts or to replace components using surface identifiers to write-access parts.“
solidworks.propertyview.autoswitchDefiniert das der Karteireiter Anhangteile aktiv geschaltet wird, wenn das Dokument Anhangteile besitzt. Wenn Varianten vorhanden sind, wird der Karteireiter Varianten aktiv geschaltet (SolidWorks Rollup).
solidworks.propertyview.configurations
solidworks.propertyview.defaulttabDas System merkt sich den zuletzt aktiven Karteireiter für den nächsten Programmaufruf.
solidworks.propertyview.documentDefiniert ob der Karteireiter Dokument angezeigt wird (Im speedy Rollup Fenster in SolidWorks)
solidworks.propertyview.filesDefiniert ob der Karteireiter Dateien angezeigt wird.
solidworks.propertyview.libraryDefiniert ob der Karteireiter Anhangteile angezeigt wird.
solidworks.propertyview.propertiesDefiniert ob der Karteireiter Eigenschaften angezeigt wird.
solidworks.propertyview.relationsDefiniert ob der Karteireiter Relationen angezeigt wird.
solidworks.propertyview.revisionsDefiniert ob der Karteireiter Versionen angezeigt wird
solidworks.relation.forceupdateDefiniert ob beim Speichern einer SolidWorks Baugruppe die Relationen immer aktualisiert werden sollen.
solidworks.relation.includesuppressed Relationen von unterdrückten Komponenten speichern.
solidworks.revision.count Anzahl Revisionseinträge in der Revisionstabelle.
solidworks.revision.first Erste anzuzeigende Revision. Ein Wert von 1 bedeutet die Revisionstabelle beginnt mit der 1. Freigabe.
Standardwert := 1
solidworks.revision.firstline Nur 1. Zeile des Änderungskommentars in die Versionstabelle schreiben.
solidworks.revision.revlabel Formatierung der Revisionsbezeichnung im Änderungsindex
siehe auch [session.revlabel]
solidworks.revision.hidden
solidworks.revision.template
solidworks.rollup.autorefreshDefiniert ob beim aufklappen des Rollup-Fensters die Dokumentenliste automatisch aktualisiert werden soll.
solidworks.rollup.delayDefiniert in 250ms Schritten die Verzögerungszeit für das Zuklappen des Rollup-Fensters
solidworks.rollup.delta XY-Koordinaten-Versatz beim positionieren des Rollup-Fensters bzgl. der rechten oberen Ecke von Solidworks.
solidworks.rollup.dockable Zeig das speedy-Fenster entweder als andockbares Task-Fenster oder als Rollup-Fenster an.
solidworks.rollup.unrolltimerDefiniert in 250ms Schritten die Verzögerungszeit für das Aufklappen des Rollup Fensters
solidworks.rollup.show Rollup-Fenster anzeigen ja/nein.
solidworks.savebmp.autosave
solidworks.savebmp.overwrite Definiert ob eine bereits vorhandene .bmp Datei überschrieben werden soll.
solidworks.savedxf.overwrite Definiert ob eine bereits vorhandene .dxf Datei überschrieben werden soll.
solidworks.savedxf.autosave Definiert ob bei „Speichern + Schließen“ automatisch DXF-Datei erzeugt wird.
solidworks.savedxf.autosave.slddrw Definiert ob bei „Speichern + Schließen“ automatisch für eine Zeichnung eine DXF-Datei erzeugt/aktualisiert wird.
solidworks.savedxf.autosave.sldprtDefiniert ob bei „Speichern + Schließen“ automatisch für ein Teil eine DXF-Datei erzeugt/aktualisiert wird.
solidworks.savedxf.modelviews Eine Aufzählung von Modellansichtsnamen, die beim Speichern eines Teils als DXF/DWG exportiert werden sollen.
Wenn der Parameter nicht definiert ist werden die Standardansichten (swFrontView, swLeftView, swTopView ) exportiert.
Die Aufzählung kann Zahlen für die vordefinierten Modellansichten beinhalten:
- swFrontView = 1,
- swBackView = 2,
- swLeftView = 3,
- swRightView = 4,
- swTopView = 5,
- swBottomView = 6,
- swIsometricView = 7,
- swTrimetricView = 8,
- swDimetricView = 9
(z.B.: „1;4;5;7“ ⇒ Es werden die Ansichten swFrontView, swRightView,swTopView und swIsometricView exportiert)
Des Weiteren kann die Aufzählung Namen von selbst zu definierenden Modellansichten beinhalten. Die Namen können dabei mit Platzhaltezeichen beschrieben werden.
(z.B.: „Export*;Lasern“) ⇒ Es werden alle Ansichten exportiert, die mit „Export“ beginnen oder „Lasern“ heißen.

Dieser Parameter wirkt NICHT bei Blechteilen.
solidworks.savedxf.persheet Definiert ob alle Blätter einer Zeichnung in eine DXF/DWG gespeichert werden oder pro Blatt eine DXF/DWG gespeichert wird.
solidworks.savedxf.sheetmetaloptions Definiert welche Linien/Elemente beim Speichern von Abwicklungen zusätzlich gespeichert werden.
1 := to export flat-pattern geometry
2:= to include hidden edges
4 := to export bend lines
8 := to include sketches
13:= to include bend lines, flat-pattern geometry and sketches
16 := to merge coplanar faces
32 := to export library features
64 := to export forming tools
2048 := to export bounding box
Siehe auch Solidworks API „ExportToDWG2“ → „SheetMetalOptions“.
Standardwert := 1
solidworks.saveedrawing.overwriteDefiniert ob eine bereits vorhandene .edrawing Datei überschrieben werden soll
solidworks.saveedrawing.autosaveDefiniert ob bei „Speichern + Schließen“ automatisch für das Dokument eine neue .edrawing Datei erzeugt/aktualisiert wird.
solidworks.saveedrawing.autosave.sldprtDefiniert ob bei „Speichern + Schließen“ von Einzelteilen automatisch eine .edrawing Datei erzeugt/aktualisiert wird.
solidworks.saveedrawing.autosave.sldasmDefiniert ob bei „Speichern + Schließen“ von Baugruppen automatisch eine .edrawing Datei erzeugt/aktualisiert wird.
solidworks.saveedrawing.autosave.slddrwDefiniert ob bei „Speichern + Schließen“ von Zeichnungen automatisch eine .edrawing Datei erzeugt/aktualisiert wird.
solidworks.saveigs.overwriteDefiniert ob eine bereits vorhandene .igs Datei überschrieben werden soll.
solidworks.saveigs.autosaveDefiniert ob bei „Speichern + Schließen“ automatisch für das Dokument eine neue .igs Datei erzeugt/aktualisiert wird.
solidworks.saveigs.autosave.sldasmDefiniert ob bei „Speichern + Schließen“ von Baugruppen automatisch eine .igs Datei erzeugt/aktualisiert wird.
solidworks.saveigs.autosave.sldprtDefiniert ob bei „Speichern + Schließen“ von Einzelteilen automatisch eine .igs Datei erzeugt/aktualisiert wird.
solidworks.savejpg.overwriteDefiniert ob eine bereits vorhandene .jpg Datei überschrieben werden soll.
solidworks.savejpg.autosaveDefiniert ob bei speichern + schließen automatisch für die Zeichnung eine neue .jpg Datei erstellt bzw. eine ältere Version überschrieben wird.
solidworks.savepdf.autosaveDefiniert ob bei „Speichern + Schließen“ automatisch für die Zeichnung eine PDF Datei erzeugt/aktualisiert wird.
solidworks.savepdf.overwriteDefiniert ob eine bereits vorhandene .pdf Datei überschrieben werden soll.
solidworks.savesat.overwriteDefiniert ob eine bereits vorhandene .sat Datei überschrieben werden soll.
solidworks.savesat.autosave.sldasmDefiniert ob bei „Speichern + Schließen“ von Baugruppen automatisch eine .sat Datei erzeugt/aktualisiert wird.
solidworks.savesat.autosave.sldprtDefiniert ob bei „Speichern + Schließen“ von Einzelteilen automatisch eine .sat Datei erzeugt/aktualisiert wird.
solidworks.savestep.overwriteDefiniert ob eine bereits vorhandene .step Datei überschrieben werden soll.
solidworks.savestep.autosave.sldasmDefiniert ob bei „Speichern + Schließen“ von Baugruppen automatisch eine .step Datei erzeugt/aktualisiert wird.
solidworks.savestep.autosave.sldprtDefiniert ob bei „Speichern + Schließen“ von Einzelteilen automatisch eine .step Datei erzeugt/aktualisiert wird.
solidworks.savestep.versionDefiniert die Stepversion für das Speichern (entweder 203 oder 214)
solidworks.savestl.overwriteDefiniert ob eine bereits vorhandene .stl Datei überschrieben werden soll.
solidworks.savestl.autosave.sldasmDefiniert ob bei „Speichern + Schließen“ von Baugruppen automatisch eine .stl Datei erzeugt/aktualisiert wird.
solidworks.savestl.autosave.sldprtDefiniert ob bei „Speichern + Schließen“ von Einzelteilen automatisch eine .stl Datei erzeugt/aktualisiert wird.
solidworks.savetif.autosave
solidworks.savetif.captureTiff Bildschirm oder Druckgröße
0 := Bildschirmgröße
1 := Druckgröße
solidworks.savetif.compressionschemeKompressionsschema
0 := Tiff Unkomprimiert
1 := Tiff Packbits Kompression
2 := Tiff Gruppe 4 Faxkompression
solidworks.savetif.imagetypeTiff Bildart
0 := Tiff Schwarz / Weiß Bild
1 := Tiff RGB Bild
solidworks.savetif.overwriteDefiniert ob eine bereits vorhandene .tif Datei überschrieben werden soll.
solidworks.savetif.papersizeswTiffPrintPaperSize
Tiff Papiergröße
Spezielle Werte für Zeichenpapiergrößen
0 := Papier: Größe A
1 := Papier: Größe A Vertikal
2 := Papier: Größe B
3 := Papier: Größe C
4 := Papier: Größe D
5 := Papier: Größe E
6 := Papier: Größe A4
7 := Papier: Größe A4 Vertikal
8 := Papier: Größe A3
9 := Papier: Größe A2\\10 := Papier: Größe A1
11 := Papier: Größe A0
12 := Benutzerdefinierte Papier Größe
solidworks.savetif.resolutionTiff Druck DPI
0 := Nur für Zeichnungen
1 :=Tiff Bildschirm- oder Druckgröße muss auf 1 gesetzt werden.
solidworks.savetif.scalefactorTiff Druckmaßstabsfaktor
0 := Maßstabsfaktor: Integer Wert
solidworks.savetif.scaletofit Siehe auch Solidworks API Help.
swTiffPrintScaleToFit
„For drawings only; specifies whether to scale drawing to fit page. „
solidworks.script.shutdownDefiniert eine ausführbare Datei die beim beenden ausgeführt werden soll (z.B. .batch, .exe)
solidworks.script.startupDefiniert eine ausführbare Datei die beim Start ausgeführt werden soll (z.B. .batch, .exe)
solidworks.teamworkDefiniert ob die Teamwork Funktion aktiv ist
solidworks.template.dina0
solidworks.template.dina1
solidworks.template.dina2
solidworks.template.dina3
solidworks.template.dina4h
solidworks.template.dina4q
solidworks.template.npart_block
solidworks.template.vstl_head
solidworks.template.vstl_pos
solidworks.toolboxpartfolderDefiniert das Basisverzeichnis der Toolboxteile
solidworks.variable.dynamic Präfix für dynamische Variablen bei Variantenkonstruktion.
Mit Hilfe der Formel „swx_dynamic“ können dynamische Variablen beim Erstellen einer neuen Variante abhängig von den anderen Variablen berechnet werden.
solidworks.variable.needprefix Es werden nur dann Varianten erzeugt, wenn Bemassungsvariablen mit Präfix verlangt und auch entsprechend vorhanden sind. D.h. Von Modellen ohne entsprechende Bemassungsvariablen werden keine Varianten erzeugt.
Standardwert:=0
solidworks.variable.prefix Definiert die Vorsilbe die Variablen vorangestellt werden muss damit sie von speedy beachtet werden.
Standardwert:=var_
solidworks.variable.prefix1
solidworks.variable.quantity Definiert eine Bemassungsvariable, die zur Bestimmung der Menge eine Variante innerhalb einer Baugruppe dient.
Standardwert:=var_quantity
solidworks.variant.filetype– sonplas VIS –
solidworks.variant.table.fixedcolumnsAufzählung der festen Spalten
Spaltenüberschrift1=Dokumenteigenschaft;
Spaltenüberschrift2=Dokumenteigenschaft;
Die Aufzählungen werden durch ein Semikolon voneinander getrennt.
solidworks.variant.table.titleDefiniert den Titel der Variantentabelle (z.B. Variantentabelle)
solidworks.variant.table.anchortypeAnkerpunkt der Variantentabelle
1 := Links oben
2 := Rechts oben
3 := Links unten
4 := Rechts unten
solidworks.variant.table.useranchorpointDefiniert ob entweder die Koordinaten oder der Ankerpunkt in der Variantentabelle verwendet werden soll.
solidworks.variant.table.insertpointxEinfügekoordinaten
solidworks.variant.table.insertpointyEinfügekoordinaten
solidworks.view.internalDefiniert das SolidWorks Dateien zum Viewen in SolidWorks geöffnet werden unabhängig davon welcher Viewer in speedy definiert ist.