Dokumente

Dokumentenstatus

Dokumente befinden sich in bestimmten Zuständen, in denen berechtigte Benutzergruppen Aktionen mit ihnen durchführen können, und zwar mit Lese- oder Schreibzugriff. In der Dokumentanzeige wird dies durch ein entsprechendes Symbol dargestellt.

Symbol Status Bedeutung
Nur Anzeige Das Dokument kann nur zum Ansehen geöffnet werden.
Gesperrt Das Dokument kann nicht bearbeitet und auch nicht angesehen werden.
Erstellt Das Dokument ist erstellt und kann zur Bearbeitung entnommen werden.
Abgelegt Das Dokument ist abgelegt und kann zur Bearbeitung entnommen werden.
In Arbeit Das Dokument ist in Bearbeitung. Der Bearbeitende Anwender wird zusätzlich angezeigt.
Freigegeben Das Dokument ist freigegeben.
Wartet auf Prüfung Das Dokument ist abgelegt und muss vom zuständigen Anwender geprüft werden.
Geprüft Das Dokument wurde geprüft und muss vom zuständigen Anwender freigegeben werden.
Artikelstamm in Arbeit Die Eigenschaften des Dokuments werden zurzeit bearbeitet.
Stückliste in Arbeit Die Stückliste ist in Arbeit.
Verknüpfung Es gibt für das Dokument eine Verknüpfung.
In Arbeit durch aktuellen User Das Dokument ist durch den aktuellen Anwender in Arbeit.

Zusatzinformationen zum Dokument

Symbol Bedeutung
Das Dokument enthält Anhangteile
Das Dokument ist ein Variantenteil
Das Dokument ist eine Variantenbaugruppe
Das Dokument ist ein flexibles Einbauteil /Baugruppe
Das Dokument ist ein Variantenteil mit Anhangteilen
Das Dokument ist eine Variantenbaugruppe mit Anhangteilen
Das Dokument ist ein flexibles Teil/Baugruppe mit Anhangteilen
Am Dokument wurde die letzte Freigabe zurückgenommen und das Dokuemnt wartet auf eine erneute Freigabe.
Der Eintrag ist eine Verknüpfung zu einem Dokument.
Es existieren zusätzliche Notizen zu dem Dokument.
Es existieren Redlinings zu dem Dokument.
Das Dokument muss synchronisiert werden.

Dokumentenliste

Die Dokumentliste zeigt alle Dokumente im aktuell gewählten Ordner an.

dokulist_1.jpg

Durch markieren eines Dokuments in der Liste werden die Dokumenteigenschaften angezeigt.


In der Titelleiste der Dokumentliste wird der aktuell gewählte Ordnerpfad angezeigt. Durch klicken auf einen Ordnerpfadnamen wechseln Sie in den entsprechenden darüber liegenden Ordner.


Wenn Sie die mittlere Maustaste drücken wird ein Tooltip - Fenster mit weiteren Dokumenteigenschaften angezeigt.




Eigenschaften Öffnet die Artikelstammmaske zum Bearbeiten oder Ansehen der Dokumenteigenschaften.
Neu Erstellt ein neues Dokument.
Kopieren Kopiert das markierte Dokument.
Löschen Löscht die markierten Dokumente.
ViewZeigt das Dokument im Viewer an.
ÖffnenNimmt das Dokument in Arbeit (auschecken) und öffnet die Dokumentdatei in der entsprechenden Anwendung zum Bearbeiten. Der Status des Dokuments ist „In Arbeit“
Öffnen ZeichnungNimmt das Dokument in Arbeit und öffnet die Zeichnungsdatei in der entsprechenden Anwendung zum Bearbeiten.
Öffnen mit AuswahlSie können die zu öffnende Dokumentdatei auswählen.
Rückgängig Macht das letzte in Arbeitnehmen wieder Rückgängig.
Ablegen Legt das Dokument ab (einchecken). Andere Anwender können wieder auf das Dokument zugreifen. Der Status des Dokuments ist „Abgelegt“.
Freigeben Setzt den Status des Dokuments auf „Freigegeben“.
Freigabe zurücknehmen Die letzte Freigabe wird zurückgenommen. Das Dokument erhält den Status „In Arbeit“.
Freigabe aufheben Hebt die Freigabe auf. Das Dokument erhält anschließend des Status „In Arbeit“.
Teilverwendung Zeigt die Teileverwendung des Dokuments an.
Gehe zu Ablageordner Navigiert zum Ablageordner des markierten Dokuments.
Gehe zu „Ersetzt durch“ Navigiert zum Dokument welches als Ersatzdokument defineirt ist.
Aktualisieren Aktualisiert die aktuelle Dokumentenliste.



Dokumentlisten-Tabs (Register)

Im Standard existiert eine Dokumentliste zur Anzeige der Dokumente, die sich im gewählten Ordner befinden oder aus der Suche heraus ergeben.
Tabs erlauben das schnelle Umschalten zwischen mehreren verschiedenen Dokumentlisten.

documentlist_tabs.jpg

Der aktive Tab erhält einen neuen Inhalt, wenn in der Struktur ein neuer Ordner gewählt wird.
Ein Tab behält also den Inhalt solange bis eine neuer Ordner in der Struktur gewählt wird.

Kontextmenü zur Steuerung der Tabs
Ein Rechtsklick auf eine Tab öffnet ein Kontextmenü:

documentlist_tabs_menu.jpg
Neuer Tab Strg+T Erstellt einen neunen leeren Tab und aktiviert diesen.
Diesen Tab schließen Strg+W Schließt den aktiven Tab. Der vorherige Tab wird aktiviert.
Alle Tabs schließen Strg+Umsch+W Schließt alle Tabs außer dem ersten Tab.
Gehe zu… Synchronisiert die Navigationsstruktur mit dem aktiven Tab.
Bei aktiviertem Konfigurationsparameter [structure.synctoactivetab] wird automatisch beim Wechsel zwischen den Tabs das entsprechende Elternelement in der Struktur selektiert.

Um einen Tab zu aktivieren klicken Sie mit der Maus auf den Tab.
Durch Klick mit der mittleren Maustaste auf einen Tab wird dieser ebenfalls geschlossen.
Der erste Tab kann nicht geschlossen werden.
Der Name eines Tabs entspricht immer dem aktuellen Elternelement außer beim ersten Tab.
Beim Verweilen mit dem Mauszeiger über einem Tab zeigt ein Tooltip den aktuellen Ordnerpfad an.

Schnelles erstellen eines neuen Tabs
Durch gedrückt halten der Umschalttaste (Shift-Taste) bei allen Funktionen, die einen neuen Inhalt der Dokumentliste zur Folge haben, wird automatisch ein neuer Tab mit dem Ergebnis erstellt. Dies sind z.B.:

  • Klick auf einen Ordner
  • Direktsuche
  • Teileverwendung > Suchergebnisse
  • Gehe zu Ablageordner
  • Stückliste > Artikel anzeigen / Alle Artikel anzeigen




Dokumentenversionen

Dokumente mit Versionierung durchlaufen typischerweise folgende Zustände:

Dokumentdateien können nur beim Status „In Arbeit“ verändert werden. Die Dokumenteigenschaften können außer bei freigegebenen Dokumenten jederzeit verändert werden. Es entsteht automatisch eine neue Version.

Nimmt ein Anwender ein Dokument „In Arbeit“ hat kein anderer Anwender Zugriff auf das Dokument. Nach der Freigabe eines abgelegten Dokuments erhöht sich auch seine Revisionsnummer. Der Änderungstand eines Dokuments setzt sich aus Revisions- und Versionsnummer zusammen.

Bsp.: Revision 3.6 = 6. Version, die von der 3. Revision abgeleitet ist










Neues Dokument anlegen

Ribbon: Dokument » Neu {[Strg]+[N]}

Kontextmenü: Dokumentliste » Neu

Werkzeugkasten: Neu

Bevor ein neues Dokument angelegt werden kann, muss der Projektordner ausgewählt werden.

Dokumentnummer
Zeigt die neue Dokumentnummer an. Die Dokumentnummer wird automatisch vom System vergeben. Je nach Konfiguration kann hier eine „sprechende“ oder klassifizierende Nummer erstellt werden. Die Dokumentnummer ist eindeutig im gesamten System.
Erstellen in
Definiert den Ordner, in dem das neue Dokument abgelegt wird. Es muss ein Ordner gewählt werden.
Dokumenttyp
Definiert den Dokumenttyp des neuen Dokuments. Es muss ein Dokumenttyp gewählt werden. Je nach Konfiguration ist mit der Auswahl eines Ordners bereits der Dokumenttyp vordefiniert.
Benennung1/Benennung2
Definieren Sie einen Titel für das neue Dokument. Der Titel wird in Verbindung mit der Dokumentnummer zur Generierung des Dateinamens verwendet.
Vorlagedatei
Wählen Sie eine Vorlagedatei für das neue Dokument. Mit dem Dokumenttyp ist eine Liste von Vorlagedateien verknüpft.

Wenn alle Eingaben gemacht wurden bestätigen Sie den Dialog mit OK. Es erscheint anschließend der Eigenschaftendialog, um weitere Dokumentmerkmale zu definieren.

Dokumenteneigenschaften

Karteireiter Eigenschaften

Zeigt allgemeine und spezielle Eigenschaften eines Dokuments an. Wie z.B der Hersteller, die Verschiedenen Kommentare dazu oder das Gewicht eines Artikels.



Karteireiter Versionen

Zeigt die Versionen und Revisionen eines Dokuments an. Es wird jedes Dokument mit dem Status, dem Bearbeiter und der Dokument-ID angezeigt.

Menüoptionen:

ViewZeigt die gewählte Version im Viewer an.
ÖffnenÖffnet die gewählte Version in der zugehörigen Anwendung mit Schreibschutz.
Aktuell setzenMacht die gewählte Version zur aktuellen Version. Es wird eine neue Version am Ende der Versionsliste erzeugt mit den Daten der gewählten Version.
Unterschiede anzeigenZeigt die Unterschiede der gewählten Version zur aktuellen Version an.
Freigabe bereinigenLöscht alle Versionen zwischen der gewählten Revision und der vorherigen Revision.
EigenschaftenZeigt die Dokumenteigenschaften der gewählten Version an.

Karteireiter Dateien

Zeigt alle Dateien an, die bei diesem Dokument hinterlegt wurden. Es können Dokumente per Drag&Drop oder per Menüoptionen hinzugefügt werden. Desweiteren können aus Vorlagen die durch den Dokumenttyp festgelegt werden ausgewählt werden.

Menüoptionen:

ViewZeigt das gewählte Dokument im Viewer an.
ÖffnenÖffnet die markierte Datei in der zugehörigen Anwendung zum Bearbeiten.
AblegenLegt das Dokument ab (einchecken). Andere Anwender können wieder auf das Dokument zugreifen. Der Status des Dokuments ist „Abgelegt“.
Vorlage hinzufügenFügt eine neue Dokumentdatei basierend auf einer definierten Vorlage hinzu.
Datei hinzufügenFügt eine beliebige Datei dem Dokument hinzu.
Datei löschenLöscht die markierte Datei.
ExportierenExportiert die markierte Datei in ein lokales Verzeichnis.
Nachricht senden… Sendet die markierte Datei als Anhang an eine Email. Das Email-Fenster Ihrer Email Anwendung wird geöffnet.
Zip senden… Sendet die markierte Datei als ZIP gepackt als Anhang an eine Email. Das Email-Fenster Ihrer Email Anwendung wird geöffnet.
Eigenschaften

Karteireiter Relationen

Zeigt vom Dokument verwendete (Relation/Referenzen) Dokumente an. Andere Artikel/Dokumente die für dieses Dokument gebraucht werden. Mit Doppelklick darauf erscheinen nähere Informationen. Man kann Relationen hinzufügen indem man: Rechte Maustaste > Relation hinzufügen



Menüoptionen:

ViewZeigt das gewählte Dokument im Viewer an.
Relationen hinzufügenFügt eine neue Relation zu einem anderen Dokument hinzu.
Relation löschen Löscht die markierte Relation.
Relationen aktualisieren Aktualisiert die Relationen.
Verknüpfungseigenschaften Zeigt die Verknüpfungseigenschaften an.
EigenschaftenZeigt die Dokumenteigenschaften des referenzierten Dokuments an.

Karteireiter Teileverwendung

Zeigt die Teileverwendung an. Die Liste zeigt alle Baugruppen an, in denen das Dokument verbaut ist. Mit Doppelklick erscheinen nähere Informationen.

Menüoptionen:

ViewZeigt das gewählte Dokument im Viewer an.
Teileverwendung aktualisieren Aktualisiert die Teileverwendungsliste.
EigenschaftenZeigt die Dokumenteigenschaften des referenzierenden Dokuments an.

Karteireiter Varianten

Hier werden alle Varianten(abstammende Artikel) die es von einem Artikel gibt angezeigt. Mit Doppelklick erscheinen nähere Informationen.

Menüoptionen:

ViewZeigt das gewählte Dokument im Viewer an.
Relation löschen Löscht die markierte Variante.
EigenschaftenZeigt die Dokumenteigenschaften des Variantendokuments an.

Karteireiter Anhangdokumente

Zeigt alle Anhangteile an.

Anhangteile sind Verknüpfungen zu anderen Artikeln, die in einem Zusammenhang zu diesem Artikel bestehen oder, die häufig mit diesem verbaut werden. Beispiel: Mit einem Zylinder wird häufig ein Näherungsschalter verbaut. Der Zylinder erhält als Anhangteil den Näherungsschalter. Wenn Sie nun in Solidworks den Zylinder suchen, um ihn in eine Baugruppe einzubauen steht Ihnen der passende Näherungsschalter ebenfalls sofort zur Verfügung und muss nicht erst gesucht werden.

Menüoptionen:

ViewZeigt das gewählte Dokument im Viewer an.
ÖffnenNimmt das Dokument in Arbeit (auschecken) und öffnet die Dokumentdatei in der entsprechenden Anwendung zum Bearbeiten. Der Status des Dokuments ist „In Arbeit“
Öffnen Zeichnung Nimmt das Dokument in Arbeit (auschecken) und öffnet die Dokumentdatei in der entsprechenden Anwendung zum Bearbeiten. Der Status des Dokuments ist „In Arbeit“
Öffnen mit Auswahl Sie können die zu öffnende Dokumentdatei auswählen.
AblegenLegt das Dokument ab (einchecken). Andere Anwender können wieder auf das Dokument zugreifen. Der Status des Dokuments ist „Abgelegt“.
FreigebenSetzt den Status des Dokuments auf „Freigegeben“.
Anhangteil hinzufügen Fügt einen neuen Verweis hinzu.
Anhangteil löschenLöscht den Verweis.
EigenschaftenZeigt die Dokumenteigenschaften des verknüpften Dokuments an.

Karteireiter Notizen

Hier können per Drag&Drop Notizen zu Dokumenten abgelegt werden. In der Menüleiste besteht die möglichkeit direkt Notizen anzulegen.



Dokumenteneigenschaften bearbeiten

- Ribbon: Dokument> Eigenschaften {[Strg]+[E]}
- Kontextmenü: Eigenschaften {[Strg]+[E]}
- Werkzeugkasten Eigenschaften
- Doppelklick auf das Dokument in der Dokumentenliste

Öffnet den Eigenschaften Dialog, um die Dokumenteigenschaften zu bearbeiten

Karteireiter Allgemein

Zeigt allgemeine System-Informationen zum Dokument an. Es können Daten verändert oder ein Kommentar dazu geschrieben werden. Es werden Hersteller, Lieferant, Preis, Material, usw. abgefragt.


Bedeutung der Eingabefelder:

Dokumentname Hier wird der vollständige Dokumentname dargestellt.
Wird ein Artikel (Teil/Baugruppe) einmal verwendet ist der Dokumentname rosa hinterlegt.
Wird ein Artikel (Teil/Baugruppe) mehrmals verwendet ist der Dokumentname rot hinterlegt.
Wurde der Artikel bereits einmal exportiert erscheint der Dokumentname in blauer Schrift.
DokumenttypZeigt den Dokumenttyp an.
Benennung 1/2/3Artikelbenennung
HerstellerHersteller
LieferantLieferant
ErsatzteilKennzeichnung, ob der Artikel ein Ersatzteil ist und in der Ersatzteilstückliste ausgegeben werden soll.
MengeneinheitWählen sie eine Mengeneinheit aus der Liste aus.
PreisHier wird der Preis pro Mengeneinheit angegeben.
MaterialGeben Sie einen Materialnamen ein oder wählen Sie ein Material aus der Liste aus.
Durch Auswahl der Schaltfläche Material können Sie ein Material in der Materialdatenbank suchen.
OberflächeGeben Sie eine Oberflächenbeschaffenheit ein oder wählen Sie ein aus der Liste aus.
Durch vorherige Auswahl eines Materials wird die Auswahlmöglichkeit der Liste entsprechend der Materialeigenschaften eingeschränkt.
GewichtGibt das Bauteilgewicht anhand der von Solidworks berechneten Daten an.
Das Gewicht hängt bei Einzelteilen von der Dichte ab, die mit dem Material definiert wird.
AbmessungenAbmessungen des Bauteils. (z.B. Länge, Breite, Höhe, Dicke, …) abhängig vom Abmessungstyp
GrößeGibt die Größe des Bauteils anhand der in Solidworks konstruierten Geometrie an.

Karteireiter Eigenschaften

Zeigt die kundenspezifischen Artikeleigenschaften eines Dokuments an. Es können Werte verändert werden. Hauptsächlich werden die vorherigen Einstelungen angezeigt, die dann aber noch genauer beschrieben werden.


Karteireiter Varianten

Zeigt alle Varianten (Kindartikel) eines Variantenartikels an. Es können Variablen geändert werden. Mit [STR]+[Mausklick] öffnet sich der Formeleditor bei Variantenartikeln. Damit lässt sich eine Formel formulieren nachdem die Varianten eines Artikels z.B benannt werden.

Siehe Variantenartikel

Karteireiter Versionen

Hier kann man die Verschiedenen Versionen betrachten, ihren Status sehen und die Bearbeitende Person herausfinden. Es wird Angezeigt von welchem Benutzer und zu welcher Zeit der Artikel Erstellt wurde. Im unteren Fenster werden alle bisher dagewesenen Versionen dieses Artikels Angezeigt. Wenn der Artikel kopiert wurde gibt das Feld URSPRUNG den Hinweis auf den Ursprung der Kopie.

Dokument entnehmen/öffnen

Ribbon: Dokument » Öffnen {[Strg]+[O]}
Werkzeugkasten Entnehmen
Werkzeugkasten Öffnen
Kontextmenü Dokumentliste » Öffnen
Markieren Sie die zu öffnenden Dokumente in der Dokumentliste. Die Dokumente erhalten den Status In Arbeit und können nun von Ihnen bearbeitet werden bzw. die dem Dateityp zugeordnete Anwendung wird gestartet und die Dokumentdatei wird zur Bearbeitung geöffnet. Während ein Dokument entnommen ist und den Status In Arbeit hat, kann es von anderen Anwendern nicht bearbeitet werden, das Dokument ist für andere Anwender gesperrt. Ist das Dokument freigegeben erfolgt eine zusätzliche Sicherheitsabfrage. Sie haben die Auswahl das Dokument nur lesend zu öffnen oder die Freigabe aufzuheben und das Dokument zu bearbeiten.


Öffnen mit Auswahl

Menü: Datei > Öffnen mit Auswahl
Kontextmenü: Öffnen mit Auswahl
Öffnet ein Fenster in dem man die Datei die man bearbeiten möchte auswählen kann.

Dokument ablegen

Ribbon: Dokument » Ablegen {[Strg]+[S]}
Werkzeugkasten Ablegen
Kontextmenü Dokumentliste » Ablegen
Markieren Sie die abzulegenden Dokumente in der Dokumentliste. Die Dokumente erhalten den Status Abgelegt und können nun von anderen Anwendern wieder bearbeitet werden. Wenn das Dokument zuvor Freigegeben war erfolgt eine zusätzliche Abfrage.

Neue Freigabe
Dokumente werden abgelegt und direkt wieder freigegeben.

Dokument ablegen
Dokumente werden nur abgelegt. Eine neue Freigabe kann später erstellt werden.

Aktuelle Freigabe belassen
Alle Änderungen werden verworfen.


Dokument freigeben

Ribbon: Dokument » Freigeben {[Strg]+[R]}
Werkzeugkasten Freigeben
Kontextmenü Dokumentliste » Freigeben

Freigabedialog

Markieren Sie alle freizugebenden Dokumente in der Dokumentliste. Die Dokumente erhalten den Status freigegeben.
Alle Dateien eines freigegebenen Dokuments werden in einem speziellen Verzeichnis festgehalten, sodass bei weiterer Bearbeitung (neue Version) der freigegebene Stand erhalten bleibt. Es kann jederzeit der Dateistand einer älteren Freigabe abgerufen werden. Dies gilt selbstverständlich auch für Baugruppen und deren Referenzen auf weitere Baugruppen und Teile.

Der Freigabe-Dialog zeigt alle freizugebenden und referenzierten Dokumente an.
In der Tabelle kann für jedes Dokument manuell auch eine andere „Neue Version“ vergeben weden.
Für jedes Dokument kann ein Freigabekommentar vergeben werden. Bei aktiviertem Schalter „Wertänderung in alle Dokumente übertragen“ wird ein einmal eingegebener Kommentar in alle Dokumente übertragen. Der Schalter muss gesetzt sein bevor ein Kommentar eingegeben wird, damit die Werte übernommen werden.
Der Freigabekommentar kann z.B. im Schriftkopf einer Zeichnung im Änderungsindex angedruckt werden.

Es stehen folgende weitere Optionen bei der Freigabe zur Verfügung:

Stückliste als PDF speichern
Die Stücklisten werden mit der Freigabe zusätzlich als PDF-Datei am Artikel abgespeichert.
(Siehe auch Konfigurationsparameter [document.release.bomfiletype])

Export an ERP
Die Artikel- und Stücklistendaten werden bei der Freigabe an das ERP System übergeben.
(Siehe auch Konfigurationsparameter [session.export.onrelease])

Nachricht senden
Nach der Freigabe erfolgt eine Nachricht an alle eingstellten Empfänger.
(Siehe auch Konfigurationsparameter [document.release.message.xxx])

Arbeitsdatei auf Freigabe referenzieren
Die Refrenzen der Arbeitsdateien von Baugruppen werden ebenfalls auf die freigegebenen Dateien umreferenziert.
(Siehe auch Konfigurationsparameter [document.release.relink.work])

Neutralformate erstellen
Neutralformate werden erstellt oder erneuert.
Der Schalter ist ein 3-wertiger Schalter:
Bei deaktiviertem Schalter werden keine Neutralformate erstellt.
Bei aktiviertem Schalter werden von allen Dateien, egal ob dies bereits freigeben sind, Neutralformate erstellt.
Bei teilweise aktiviertem Schalter werden nur von neu freizugebenden Dateien Neutralformate erstellt.


Prüfen
Es wird bei allen noch nicht freigegebenen Dokumente geprüft, ob evtl. definierte Pflichtfelder im Artikelstamm auch Ordnungsgemäß ausgefüllt sind.
Die Prüfung kann manuell durch Klick auf die Schaltfläche „Prüfen“ erfolgen andernfalls erfolgt die Prüfung automatisch vor der Freigabe.
Sollten Pflichtfelder nicht ausgefüllt sein erfolgt eine entsprechende Fehlermeldung.

Durch Doppelklick auf einen Eintrag in der Liste wird der Artikelstamm geöffnet.
Bitte beachten Sie bei Baugruppen, die Unterteile enthalten, erfolgt der Aufruf des Artikelstamms nur bei gedrückter Steuerungstaste.

Einige Optionen können je nach administrativer Einstellung (Konfigurationsparameter ist als Global definiert) im Dialog nicht vorhanden oder ausgegraut sein.



Der einfache Freigabedialog kann durch deaktivieren des Konfigurationsparameters [document.release.extended] verwendet werden.

Einfacher Freigabedialog



Dokument ansehen

Ribbon: Datei » View {[Strg]+[Q]}
Werkzeugkasten View
Kontextmenü Dokumentliste » View
Markieren Sie die Dokumente, die Sie im Viewer ansehen möchten. Der mit dem entsprechenden Dateityp verknüpfte Viewer wird gestartet und zeigt die Dokumentdatei an. Wenn keine spezielle Viewer – Anwendung definiert ist wird die Dokumentdatei in der passenden Anwendung im schreibgeschützten Modus geöffnet. Wenn es mehrerer Dateien für das gewählte Dokument gibt müssen Sie noch die anzusehende Datei auswählen

Dokumentvorschau

Wenn Sie ein Dokument in der Dokumentliste markieren wird in der Dokumentvorschau eine Schnellansicht dargestellt. Existieren mehrere Dateien für das markierte Dokument wird für jede Datei ein Karteireiter mit der entsprechenden Schnellansicht dargestellt. Durch klicken auf einen Karteireiter wird die entsprechende Schnellansicht dargestellt.

Durch drücken der mittleren Maustaste im Bereich der Dokumentvorschau können Sie bei einigen Dateitypen die Schnellansicht vergrößern. Die Vergrößerung erfolgt entweder bildschirmfüllend oder in der zur Verfügung stehenden Ansichtsgröße.

Teileverwendung

Ribbon: Eigenschaften » Teileverwendung
Kontextmenü: Teilverwendung
Zeigt die ausführliche Teileverwendung des Dokuments an.

Dokumente vergleichen

Ribbon: Eigenschaften » Dokumente vergleichen
Zeigt die ausgewählten Dokumente an und vergleicht diese Anhand des zu erst gewählten Dokuments. Die Unterschiede werden mit einem Rot markiertem Text angezeigt. In diesem Dialog kann nichts bearbeitet werden, er dient rein zu Vergleichszwecken.

Dokumente editieren (Massendateneingabe)

Ribbon: Eigenschaften » Dokumente editieren
Zeigt die ausgewählten Dokumente an. Es können nun die ausgewählten Dokumente in ihren Eigenschaften bearbeitet werden. Sobald es Schreibgeschützte Dokumente gibt werden diese grau hinterlegt. Die Kind Dokumente eines Dokuments können über den Schalter Kind Dokumente anzeigen ebenfalls bearbeitet werden. Der Grundartikel ist in diesem Fall Schreibgeschützt.

Der Dialog ist wie eine Excel-Tabelle aufgebaut in der die einzelnen Zellen bearbeitet werden können. Wie von Excel gewohnt wird mit Enter aus einer Zelle in die nächste gesprungen.

Über den Schalter Wertänderung in alle Dokumente übertragen kann man die komplette Spalte automatisch ausfüllen lassen. D.h. wenn dieser Schalter gesetzt ist wird sobald sie in einem Dokument etwas verändern, dies auf alle anderen Dokumente angewendet.

Über den Schalter Wertänderung in ausgewählte Dokumente übertragen kann man eine Spalte automatisch für ausgewählte Dokumente ausfüllen lassen. D.h. wenn dieser Schalter gesetzt ist wird sobald sie in einem Dokument etwas verändern, dies auf alle momentan ausgewählten Dokumente angewendet. Mehrere Dokumente können ausgewählt werden in dem die Strg-Taste beim Klicken gedrückt ist oder über die Umschalt-Taste ein Bereich gewählt ist. Den gewünschten Wert dann einfach eintippen. Der Dialog übernimmt dann die Werte in die markierten Zeilen.

Es können für die Massendateneingabe Spaltenbeschreibungen definiert werden. Diese Spaltenbeschreibungen müssen vom Typ „massedit-Dokument Massendaten bearbeiten“ sein. Werden mehrere Spaltenbeschreibungen definiert können diese durch eine Auswahlliste im Dialog ausgewählt werden. Der Dialog merkt sich die zuletzt ausgewählte Spaltenbeschreibung und öffnet den Dialog beim nächsten mal mit dieser.

Referenz Manager

Ribbon: Dokument » Eigenschaften » Referenz Manager


Dokument kopieren

Ribbon: Datei » Kopieren
Werkzeugkasten Kopieren
Kontextmenü Dokumentliste » Kopieren
Erstellt eine Kopie des gewählten Dokuments.

In der Struktur werden das Dokument und alle zugehörigen Dateien angezeigt. Das zur Kopie gewählte Dokument ist bereits markiert. Handelt es sich bei dem zu kopierenden Dokument um eine Baugruppe, die Teile oder Unterbaugruppen referenziert werden diese ebenfalls in der Struktur dargestellt und können zum Kopieren markiert werden. Der Schalter Anhangteile kopieren definiert, ob die Verweise auf Anhangteile ebenfalls kopiert werden. Durch Auswahl von Neue Artikelnummer bestimmen Sie, dass für jedes neue Dokument der Neu-Dialog zur Spezifikation der Artikelnummer oder Bezeichnung aufgerufen wird.

Kopieren per Drag and Drop

Sie können ein Dokument auch per Drag & Drop in einen anderen Ordner oder ein anderes Projekt kopieren.

Markieren Sie das Dokument in der Dokumentliste und ziehen Sie es mit gedrückter linker Maustaste über den Zielordner bis dieser grau markiert wird. Nachdem Sie die Maustaste los gelassen haben erscheint der Dokument kopieren Dialog.

Verknüpfen per Drag and Drop

Wird mit der gleichen Vorgehensweise ein Artikel in eine andere Struktur des gleichen Projektes gezogen, so wird dieser Artikel als Link im anderen Verzeichnis abgelegt (also nicht kopiert, sonder verlinkt). Dies ist am Linksymbol erkennbar.


Dokument im gleichen Projekt kopieren

Soll im gleichen Projekt der Artikel Per Drag&Drop kopiert werden, so ist die Taste [Strg] gedrückt zu halten. Das Maussymbol ändert sich zu einem [+].

Dokumenteigenschaften in die Zwischenablage kopieren

[Strg]+[C] in der Dokumentenliste kopiert die Dokument-Objekte sowie die Dokumentnummer in die Zwischenablage.
Sind mehrere Zeilen markiert werden die Dokumentnummern ebenfalls durch Zeilenumbruch getrennt in die Zwischenablage kopiert.
Ist der Mauszeiger über einer Spalte positioniert wird die Eigenschaft der Spalte, anstelle der Dokumentnummer, in die Zwischenablage kopiert.

Dokument löschen

Ribbon: Dokument » Löschen {[Strg]+[X]}
Werkzeugkasten Löschen
Kontextmenü Dokumentliste » Löschen

|

Die markierten Dokumente werden nach dem Befehlsaufruf nochmals zur Bestätigung im Dialog „Dokumente löschen“ aufgelistet. In der Liste sind alle Dokumente, die gelöscht werden können markiert. In der Liste wird symbolisiert, ob das Dokument oder eine Verknüpfung auf das Dokument gelöscht wird (siehe auch den Tooltip). dlgdocumentdelete_tooltip.jpg

Artikel, die bereits einmal exportiert wurden (Export an die Warenwirtschaft) können nur noch durch den Administrator gelöscht werden.

Dokument sperren

Es gibt die Möglichkeit über den Verwendungszweck Dokumente zu sperren und somit Änderungen, einbau in Baugruppen und Eigenschaften festzuschreiben. Das Dokument kann danach nicht mehr bearbeitet werden.
Ein User der die Berechtigung: UsageEditProperties kann sie jedoch weiterhin bearbeiten und ändern.

Nötige Einstellungen beim Verwendungszweck:

  • Bearbeiten erlauben → Nicht angehakt
  • Einfügen erlauben → Nicht angehakt
  • Benutzerrecht prüfen → angehakt
  • evtl. den Verwendungszweck aus der Direktsuche entfernen


Damit ist bei diesem Verwendungszweck dass Dokument gesperrt.

Rückgängig

Ribbon: Bearbeiten > Rückgängig {[Strg]+[R]}
Kontextmenü: Rückgängig {[Strg]+[R]}


Macht die letzte Bearbeitung eines Dokuments wieder rückgängig.

Freigabe zurücknehmen

Ribbon: Bearbeiten > Freigabe zurücknehmen

Nimmt die letzte Freigabe wieder zurück. Der Revisionszähler wird zurückgesetzt. Das Dokument kann anschließend wieder ganz normal bearbeitet werden. Das Dokument befindet sich allerdings in einem Zustand, so dass es auf eine erneute Freigabe wartet. Dies wird in der Dokumentliste durch ein entsprechendes Symbol dargestellt.


Dokumente suchen

Ribbon: Struktur > Suche {[Strg]+[F]}
Werkzeugkasten Suchen

speedy bietet verschiedene Möglichkeiten, Dokumente anhand ihrer Eigenschaften zu suchen und in einer Trefferliste (Suchergebnisse im Navigationsfenster) anzuführen. Für alle Möglichkeiten gelten folgende Kriterien:

  • Die Suche nach Dokumenten erfolgt nur innerhalb eines Schließfachs.
  • Die Suche erfolgt über die aktuellen Dokumentversionen, d. h. ältere Versionen/Revisionen werden nicht einbezogen. Im Versionsfenster wird die neueste Version/Revision markiert, die den Suchkriterien genügt.
  • Die gefundenen Dokumente werden automatisch in der Dokumentliste eingeblendet und können von hier aus bearbeitet werden.
  • Bei der Suche nach Texteinträgen kann das * oder %-Zeichen als Platzhalter für beliebigen Text eingegeben werden: Bsp.: alle Dokumente, die in der Benennung „MV5“ enthalten » *MV5* alle Dokumente, deren Benennung mit „Ein“ beginnt » Ein*
  • Bei der Suche nach Texteinträgen kann das ?-Zeichen als Platzhalter für ein beliebiges Zeichen eingegeben werden.
  • Bei Texteinträgen wird zwischen Groß- und Kleinschreibung nicht unterschieden.
  • Sonderzeichen (* ? % _) in der Suche können mit einem sog. Escape-Character (\) maskiert werden.

Geben Sie Ihre Suchbegriffe in die jeweiligen Eingabefelder ein.

Alle eingegebenen Suchkriterien (Eingabefelder) werden mit UND verknüpft, d.h. alle Suchkriterien müssen in den Dokumenteigenschaften erfüllt sein. Beispiel: Eingabe *Halter* in Dokumentname und Festo in Lieferant sucht alle Dokumente die den Begriff Halter im Dokumentnamen haben und als Lieferant Festo definiert haben.

Möchten Sie in einem Eingabefeld nach mehreren Kriterien suchen müssen die Suchkriterien durch ||-Zeichen getrennt werden. Beispiel: Sie möchten nach allen Artikeln suchen, die als Lieferant Bosch ODER Festo haben > Bosch || Festo.

Suchfilter:

FilterBedeutung
<> wertDer angegebene Wert darf NICHT vorkommen
> wertSuche nach Werten, die größer sind als der angegebene Wert.
< wertSuche nach Werten, die kleiner sind als der angegebene Wert.
>= wert Suche nach Werten, die größer oder gleich sind als der angegebene Wert.
⇐ wertSuche nach Werten, die kleiner oder gleich sind als der angegebene Wert.
*Beliebiger Text an der Stelle
?Beliebiges Zeichen an der Stelle
wert1 | wert2 Suche nach Wert1 oder Wert2
wert1 OR wert2
condition1 & condition2 Suche nach Bedingung1 und Bedingung1.
z.B. >50 & <80
condition1 AND condition2
wert1 :: wert2 Wertebereich zwischen Wert1 und Wert2
wert1 BETWEEN wert2

Wenn Sie immer wieder nach den gleichen Begriffen suchen müssen können Sie hierzu einen Suchfavoriten ablegen. Definieren Sie Ihre Suchbegriffe im Suchdialog. Anschließend geben Sie den gewünschten Favoritennamen in der Kombinationsliste (linke untere Ecke des Suchen Dialogs) ein und betätigen den Speichern Schaltknopf.

Die Suchfavoriten stehen Ihnen zum schnellen Zugriff im Aufklappmenü unterhalb der Suchen Schaltfläche direkt zur Verfügung:

Schnellsuche

Mit der Schnellsuche können Sie eine Dokumentsuche auslösen, die automatisch in den wichtigsten Datenfeldern der Dokumenteigenschaften sucht.

Werkzeugkasten Schnellsuche

Geben Sie einfach den gesuchten Begriff in das Schnellsuchfeld ein und bestätigen Sie mit der Eingabetaste. Beispiel: Sie suchen einen Zylinder: Eingabe in der Schnellsuche Zyl

Es werden alle Artikel aufgelistet die Zyl im Dokumentnamen, der Benennung1, Benennung 2, Benennung 3, Lieferant, Material oder Oberfläche haben.
Sie suchen alle Teile, die als Oberflächenbehandlung eloxiert sind: Eingabe in der Schnellsuche eloxiert

Dateien importieren

Ribbon: File » Importieren » Datei importieren

Importiert eine oder mehrere gewählte Dateien und erstellt daraus jeweils ein speedy/PDM Dokument. Wechseln Sie vor dem Befehlsaufruf in den gewünschten Ablageordner mit Hilfe des Navigationsbaums. Nach Befehlsaufruf werden Sie aufgefordert eine oder mehrere Dateien auszuwählen. Der Dialog für ein neues Dokument wird angezeigt. Der Dateiname wird bereits als Benennung vorgeschlagen. Nehmen Sie weitere Einstellungen vor und bestätigen Sie den Dialog mit OK. Der Artikel wird angelegt und die Datei im speedy/PDM Schließfach abgelegt. Wenn Sie mehrere Dateien importieren erscheint nach dem ersten Import die Abfrage, ob die weiteren Dateien automatisch importiert werden sollen. Wird dies mit „Ja“ bestätigt, werden alle weiteren Artikel automatische importiert und abgelegt.

Speedy unterstützt das Importieren von Dateien per Windows Drag & Drop oder über die Zwischenablage.

Zu ZIP importieren
Menü: Datei > Importieren > Zu ZIP importieren
Beim Importieren von einer oder mehreren gewählte Dateien werden diese als ZIP-Datei gepackt und als ein speedy/PDM Dokument importiert.

Importieren aus Zwischenablage
Menü: Datei > Importieren > Zwischenablage
Importiert den Inhalt der Zwischenablage als neues speedy/PDM Dokument.

Schnappschuss importieren
Menü: Datei > Importieren > Schnappschuss
Importiert einen Bildschirm Schnappschuss (Screen-Shot) als neues Dokument.

TWAIN importieren
Menü: Datei > Importieren > TWAIN > Einlesen
Importiert ein Bild von einem TWAIN kompatiblen Gerät (z.B. Scanner oder Kamera). Nach Befehlsaufruf erscheint ein Gerätespezifischer Dialog. Nehmen Sie hier alle Einstellungen vor und scannen ein Bild ein. Nach erfolgreichem Scannvorgang erscheint der Neu-Dialog und fordert zu weiteren Eingaben auf. In den meisten Fällen bleibt der Scanner-Dialog aktiv und erlaubt das weitere einscannen von Bildern.

TWAIN Quelle auswählen
Menü: Datei > Importieren > TWAIN > Quelle auswählen
Erlaubt das Auswählen eines TWAIN kompatiblen Gerätes. Wenn mehrere TWAIN kompatible Geräte vorhanden sind können Sie vor dem importieren das zu verwendende Gerät auswählen.

Outlook Email importieren

Outlook – Emails können per Drag & Drop in speedy eingefügt werden: Ziehen und Halten Sie mit der linken Maustaste die Outlook – Email und lassen Sie sie im Dokumentenfenster fallen.

Es öffnet sich ein neu Dialog für E-Mails in dem alle Einstellungen für das Email-Dokument gemacht werden können.

Wenn Anhänge an der Email sind öffnet sich ein Dialog in dem man auswählen kann was mit den Anhängen passiert. Hier können allgemeine Einstellungen des Emails Dokument gemacht werden und auch Einstellungen zum Anhang. Anhänge können entweder als eigenständiges neues Dokument(Als eigenes Dokument speichern) oder als Anhangdatei an der Email angeheftet werden(Als Anhangdatei speichern). Soll die Email einfach nur so Abgespeichert werden dann kann dies mit der auswahl nicht separat Speicher gemacht werden.

Wenn der Anhang als eigenständiges Dokument gespeichert werden soll können sie die Dokumenteistellungen wie Dokumenttyp,Container und Bennenung direkt eintragen und es wird kein Neu-Dialog für den Anhang benötigt. Lassen sie z.B. den Dokumenttyp leer wird für jeden Anhang ein Neu-Dialog aufgerufen. Es werden nur Anhänge die angehakt sind eingespielt!

Exportieren

Dateien exportieren

Ribbon: SPEEDY > Export > Export Datei
Exportiert die Dateien eines oder mehrerer Dokumente in ein lokales Verzeichnis oder eine Zipdatei.
Markieren Sie alle Dokumente deren Dateien sie exportieren möchten. Sollen ganze Baugruppenstrukturen exportiert werden reicht es aus die oberste Baugruppe für den Export zu markieren. Der Exportbefehl zeigt alle von einer Baugruppe referenzierten Unterbaugruppen und Teile an.

Die Liste zeigt alle Dateien der zuvor gewählten Dokumente an. Einzelne Dateien können hier nochmals abgewählt werden. Klicken Sie zum ab- oder anwählen einzelner Dateien das jeweilige Kontrollkästchen in der Liste an.

Speichern in
Definiert ein Verzeichnis in das die Dateien exportiert werden.
ZIP Packen
Aktivieren Sie das Kontrollkästchen, um die gewählten Dateien als ZIP gepackt zu exportieren. Die Eigenschaft „Speichern in“ definiert nun einen Dateinamen für die ZIP-Datei.
Version
Wählen Sie eine bestimmte Version des Dokuments für den Export.
Revision [?] entfernen
Definiert, ob bei Revisionen die Revisionsnummer aus dem Dateinamen entfernt werden soll.
Struktur erhalten Definiert, ob die Dateiablagestruktur, wie sie auf dem Dateiserver vorhanden ist, im Export erhalten bleibt. Bei deaktivierter Option werden alle Dateien in ein Verzeichnis exportiert.
Dateityp filtern
Die Liste zeigt alle Dateitypen der zu exportierenden Dateien an. Durch aktivieren oder deaktivieren eines Dateityps werden die entsprechenden Dateien in der Dateiliste an- oder abgewählt.

In ZIP exportieren

Ribbon: SPEEDY > Export > Export als Zipdatei
Menü: Datei > Exportieren > Datei als ZIP exportieren
Exportiert die Dateien eines oder mehrerer Dokument als ZIP gepackt in ein lokales Verzeichnis. Der Dialog „Datei exportieren“ erscheint mit bereits aktiviertem Kontrollkästchen „ZIP Packen“.

Dokumentdaten exportieren

Ribbon: SPEEDY > Export > Export Metadaten
Exportiert die Dokumenteigenschaften eines oder mehrerer Dokumente. Sämtliche Dokumenteigenschaften der zuvor ausgewählten Dokumente werden in eine Datei exportiert. Es stehen Ihnen folgende Dateiformate zu Verfügung:

  • XML – Format
  • CSV – Format
  • Excel Arbeitsmappe
  • Rich Text Format

Nachricht/Zip Senden

Nachricht senden
Menü: Datei > Nachricht senden
Versendet die Dateien der markierten Dokumente per Email. Alle Dateien der zuvor markierten Dokumente werden an Anhang an eine neue Email angefügt.
ZIP senden
Menü: Datei > ZIP senden
Versendet die Dateien der markierten Dokumente per Email. Alle Dateien der zuvor markierten Dokumente werden in eine ZIP Datei gepackt und als Anhang an eine neue Email angefügt.